~ubuntu-branches/ubuntu/vivid/mygui/vivid

« back to all changes in this revision

Viewing changes to debian/patches/disable_sse.patch

  • Committer: Package Import Robot
  • Author(s): Scott Howard, Bret Curtis, Scott Howard
  • Date: 2014-09-18 17:57:48 UTC
  • mfrom: (1.1.1)
  • Revision ID: package-import@ubuntu.com-20140918175748-dd8va78mvpw1jbes
Tags: 3.2.1-1
[ Bret Curtis ]
* Updated license for majority of files from LGPL to Expat (MIT)

[ Scott Howard ]
* New upstream release
* Updated patch to add build option for system GLEW libraries
* All patches accepted upstream except shared_libraries.patch
* Bumped SONAME due to dropped symbols, updated *.symbols and package
  names
* Updated license of debian/* to Expat with permission of all authors
* Don't install Doxygen autogenerated md5 and map files (thanks
  lintian)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: disable -msse: only for x86 architectures, not all i386 support it
2
 
 default is -msse2 on *amd64
3
 
Author: Scott Howard <showard@debian.org>
4
 
 
5
 
Index: mygui/CMakeLists.txt
6
 
===================================================================
7
 
--- mygui.orig/CMakeLists.txt   2013-04-08 08:32:02.870855288 -0400
8
 
+++ mygui/CMakeLists.txt        2013-04-08 08:32:23.962855789 -0400
9
 
@@ -178,7 +178,7 @@
10
 
 
11
 
 # Set compiler specific build flags
12
 
 if (CMAKE_COMPILER_IS_GNUCXX)
13
 
-       add_definitions(-msse)
14
 
+       #add_definitions(-msse)
15
 
        if (NOT MYGUI_HIGH_LEVEL_WARNINGS)
16
 
                add_definitions(-w)
17
 
        else ()