~mfisch/brasero/update-to-3.8.0

« back to all changes in this revision

Viewing changes to debian/patches/41_fix_packagekit.patch

  • Committer: Bazaar Package Importer
  • Author(s): Rodrigo Moya
  • Date: 2011-05-18 17:53:39 UTC
  • mfrom: (1.1.47 upstream) (1.4.3 experimental)
  • Revision ID: james.westby@ubuntu.com-20110518175339-so6a6fejezs5i1pc
Tags: 3.0.0-1ubuntu1
* Rebase from Debian and GNOME3 PPA. Remaining Ubuntu changes:
* debian/control:
  - Build-Depend on dh-autoreconf, libappindicator3-dev and
    liblaunchpad-integration-3.0-dev
  - Recommends: brasero-cdrkit
  - libbrasero-media3-1 Depends on dvd+rw-tools not growisofs and
    Suggests rather than Recommends gstreamer plugin packages
* debian/patches/010_lpi.patch:
  - Launchpad integration patch
* debian/patches/012_appindicator.patch:
  - Use application indicators
* debian/rules:
  - Include autoreconf.mk
* debian/watch:
  - Watch unstable releases also

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: fix packagekit backend
2
 
Author: Marc Deslauriers <marc.deslauriers@ubuntu.com>
3
 
Forwarded: Yes
4
 
Bug: https://bugzilla.gnome.org/show_bug.cgi?id=642324
5
 
Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/brasero/+bug/718969
6
 
 
7
 
Index: brasero-2.32.0/libbrasero-utils/brasero-pk.c
8
 
===================================================================
9
 
--- brasero-2.32.0.orig/libbrasero-utils/brasero-pk.c   2011-02-13 12:38:28.000000000 -0500
10
 
+++ brasero-2.32.0/libbrasero-utils/brasero-pk.c        2011-02-13 17:06:07.000000000 -0500
11
 
@@ -85,7 +85,11 @@
12
 
 
13
 
        if (priv->values != NULL)
14
 
                g_variant_unref (priv->values);
15
 
+               priv->res = TRUE;
16
 
        g_object_unref (priv->proxy);
17
 
+
18
 
+       if (priv->loop)
19
 
+               g_main_loop_quit (priv->loop);
20
 
 }
21
 
 
22
 
 static void
23
 
@@ -258,9 +262,9 @@
24
 
 
25
 
        g_dbus_proxy_call (priv->proxy,
26
 
                                      "InstallProvideFiles",
27
 
-                                     g_variant_new ("(uass)",
28
 
+                                     g_variant_new ("(u^ass)",
29
 
                                                     xid,
30
 
-                                                    package,
31
 
+                                                    missing_files->pdata,
32
 
                                                     "hide-confirm-search,hide-finished,hide-warning"),
33
 
                                      G_DBUS_CALL_FLAGS_NONE,
34
 
                                      -1,