~noskcaj/ubuntu/trusty/xfwm4/4.11

« back to all changes in this revision

Viewing changes to debian/patches/8563.patch

  • Committer: Jackson Doak
  • Date: 2014-01-19 09:03:46 UTC
  • mfrom: (3.1.12 experimental)
  • Revision ID: noskcaj@ubuntu.com-20140119090346-e7kv45dk1sa3guvq
* Merge from Debian unstable.  Remaining changes:
  - debian/control: demote xfwm4-themes from Recommends to Suggests, per
    the 'other-p-xubuntu-cleanthemes' spec.
  - Add patch from XFCE bugzilla to fix fullscreen behavior with Qt
    based apps 

Show diffs side-by-side

added added

removed removed

Lines of Context:
3
3
Forwarded: yes
4
4
Author: Viktor Semykin
5
5
 
6
 
diff --git a/src/client.c b/src/client.c
7
 
index 4e86808..46abf9e 100644
 
6
---
 
7
 src/client.c |   16 ++++++++++------
 
8
 1 file changed, 10 insertions(+), 6 deletions(-)
 
9
 
8
10
--- a/src/client.c
9
11
+++ b/src/client.c
10
 
@@ -981,8 +981,12 @@ clientGetMWMHints (Client *c, gboolean update)
 
12
@@ -981,8 +981,12 @@ clientGetMWMHints (Client *c, gboolean u
11
13
         wc.width = c->width;
12
14
         wc.height = c->height;
13
15
 
21
23
         {
22
24
             GdkRectangle rect;
23
25
             myScreenFindMonitorAtPoint (screen_info,
24
 
@@ -3538,8 +3542,12 @@ clientScreenResize(ScreenInfo *screen_info, gboolean fully_visible)
 
26
@@ -3538,8 +3542,12 @@ clientScreenResize(ScreenInfo *screen_in
25
27
             continue;
26
28
         }
27
29
 
35
37
         {
36
38
             maximization_flags = c->flags & CLIENT_FLAG_MAXIMIZED;
37
39
 
38
 
@@ -3553,10 +3561,6 @@ clientScreenResize(ScreenInfo *screen_info, gboolean fully_visible)
 
40
@@ -3553,10 +3561,6 @@ clientScreenResize(ScreenInfo *screen_in
39
41
             wc.height = c->height;
40
42
             clientConfigure (c, &wc, CWX | CWY | CWWidth | CWHeight, CFG_NOTIFY);
41
43
         }