~ubuntu-branches/ubuntu/precise/pingus/precise

« back to all changes in this revision

Viewing changes to debian/patches/05_no_locale_alias.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Cyril Brulebois
  • Date: 2008-02-28 19:44:25 UTC
  • mfrom: (4.1.4 hardy)
  • Revision ID: james.westby@ubuntu.com-20080228194425-e8ilohlijv02kgcf
Tags: 0.7.2-2
* Fix FTBFS with gcc-4.3 by adding the missing include in
  src/input/evdev_device.cpp (Closes: #462238):
   + debian/patches/20_fix_FTBFS_with_gcc-4.3.
* Rename former patch so that the filename reflects the order in which
  the patches are applied:
   - debian/patches/data_dir.patch
   + debian/patches/10_fix_data_directory.
* Bump Standards-Version from 3.7.2 to 3.7.3, no changes needed.
* Add a dh_desktop call in the arch-dep part of debian/rules.
* Adjust the “missing-dep-for-interpreter guile” override since lintian
  now lists an alternative for that dependency.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 05_no_locale_alias.dpatch by Moritz Breit <mail@mobr.de>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Prevent installation of /usr/share/locale/locale.alias
6
 
 
7
 
@DPATCH@
8
 
diff -urNad --exclude=CVS --exclude=.svn ./intl/Makefile.in /tmp/dpep-work.jyYPGd/pingus-0.6.0/intl/Makefile.in
9
 
--- ./intl/Makefile.in  2003-04-10 23:34:16.000000000 +0200
10
 
+++ /tmp/dpep-work.jyYPGd/pingus-0.6.0/intl/Makefile.in 2005-08-07 22:29:28.000000000 +0200
11
 
@@ -72,7 +72,7 @@
12
 
 plural.$lo plural-exp.$lo localcharset.$lo localename.$lo osdep.$lo
13
 
 GETTOBJS = intl-compat.$lo
14
 
 DISTFILES.common = Makefile.in \
15
 
-config.charset locale.alias ref-add.sin ref-del.sin $(HEADERS) $(SOURCES)
16
 
+config.charset ref-add.sin ref-del.sin $(HEADERS) $(SOURCES)
17
 
 DISTFILES.generated = plural.c
18
 
 DISTFILES.normal = VERSION
19
 
 DISTFILES.gettext = COPYING.LIB-2.0 COPYING.LIB-2.1 libintl.glibc
20
 
@@ -169,15 +169,6 @@
21
 
              rm -f $$temp; \
22
 
            fi; \
23
 
          fi; \
24
 
-         $(mkinstalldirs) $(DESTDIR)$(localedir); \
25
 
-         test -f $(DESTDIR)$(localedir)/locale.alias \
26
 
-           && orig=$(DESTDIR)$(localedir)/locale.alias \
27
 
-           || orig=$(srcdir)/locale.alias; \
28
 
-         temp=$(DESTDIR)$(localedir)/t-locale.alias; \
29
 
-         dest=$(DESTDIR)$(localedir)/locale.alias; \
30
 
-         sed -f ref-add.sed $$orig > $$temp; \
31
 
-         $(INSTALL_DATA) $$temp $$dest; \
32
 
-         rm -f $$temp; \
33
 
        else \
34
 
          : ; \
35
 
        fi
36
 
@@ -251,17 +242,6 @@
37
 
            fi; \
38
 
            rm -f $$temp; \
39
 
          fi; \
40
 
-         if test -f $(DESTDIR)$(localedir)/locale.alias; then \
41
 
-           temp=$(DESTDIR)$(localedir)/t-locale.alias; \
42
 
-           dest=$(DESTDIR)$(localedir)/locale.alias; \
43
 
-           sed -f ref-del.sed $$dest > $$temp; \
44
 
-           if grep '^# Packages using this file: $$' $$temp > /dev/null; then \
45
 
-             rm -f $$dest; \
46
 
-           else \
47
 
-             $(INSTALL_DATA) $$temp $$dest; \
48
 
-           fi; \
49
 
-           rm -f $$temp; \
50
 
-         fi; \
51
 
        else \
52
 
          : ; \
53
 
        fi