~ubuntu-branches/ubuntu/raring/banshee/raring

« back to all changes in this revision

Viewing changes to debian/patches/workaround-clideps-meego.patch

  • Committer: Package Import Robot
  • Author(s): Chow Loong Jin
  • Date: 2012-01-23 23:16:49 UTC
  • mfrom: (6.3.22 experimental)
  • Revision ID: package-import@ubuntu.com-20120123231649-safm1f8eycltcgsf
Tags: 2.3.4.ds-1ubuntu1
* Merge from Debian Experimental, remaining changes:
  + Enable and recommend SoundMenu and Disable NotificationArea by default
  + Disable boo and karma extensions
  + Enable and suggest u1ms
  + Move desktop file for Meego UI to /usr/share/une/applications
  + Change the url for the Amazon store redirector
  + [08dea2c] Revert "Fix invalid cast causing ftbfs with libgpod"
* [b617fe0] Convert Ubuntu-specific patches to gbp-pq patches
* Also fixes Launchpad bugs:
  - Fixes race condition while starting (LP: #766303)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Workaround dh_clideps failing on a broken libmeego-panel DllImport
2
 
Author: Chow Loong Jin <hyperair@ubuntu.com>
3
 
Forwarded: not-needed
4
 
Applied-Upstream: no
5
 
Index: banshee/src/Extensions/Banshee.MeeGo/Makefile.am
6
 
===================================================================
7
 
--- banshee.orig/src/Extensions/Banshee.MeeGo/Makefile.am       2011-05-14 21:51:44.254191395 +0800
8
 
+++ banshee/src/Extensions/Banshee.MeeGo/Makefile.am    2011-05-14 21:51:44.347524133 +0800
9
 
@@ -15,8 +15,6 @@
10
 
        Banshee.MeeGo/PlaybackBox.cs \
11
 
        Banshee.MeeGo/SearchEntry.cs \
12
 
        MeeGo.Panel/PanelButtonState.cs \
13
 
-       MeeGo.Panel/PanelClient.cs \
14
 
-       MeeGo.Panel/PanelGtk.cs \
15
 
        MeeGo.Panel/SetPositionHandler.cs \
16
 
        MeeGo.Panel/SetSizeHandler.cs
17
 
 
18
 
Index: banshee/src/Extensions/Banshee.MeeGo/Makefile.in
19
 
===================================================================
20
 
--- banshee.orig/src/Extensions/Banshee.MeeGo/Makefile.in       2011-05-14 21:51:44.254191395 +0800
21
 
+++ banshee/src/Extensions/Banshee.MeeGo/Makefile.in    2011-05-14 21:51:44.347524133 +0800
22
 
@@ -407,8 +407,6 @@
23
 
        Banshee.MeeGo/PlaybackBox.cs \
24
 
        Banshee.MeeGo/SearchEntry.cs \
25
 
        MeeGo.Panel/PanelButtonState.cs \
26
 
-       MeeGo.Panel/PanelClient.cs \
27
 
-       MeeGo.Panel/PanelGtk.cs \
28
 
        MeeGo.Panel/SetPositionHandler.cs \
29
 
        MeeGo.Panel/SetSizeHandler.cs
30
 
 
31
 
Index: banshee/src/Extensions/Banshee.MeeGo/Banshee.MeeGo/MeeGoPanel.cs
32
 
===================================================================
33
 
--- banshee.orig/src/Extensions/Banshee.MeeGo/Banshee.MeeGo/MeeGoPanel.cs       2011-05-14 21:51:44.194191779 +0800
34
 
+++ banshee/src/Extensions/Banshee.MeeGo/Banshee.MeeGo/MeeGoPanel.cs    2011-05-14 21:59:34.871221818 +0800
35
 
@@ -40,7 +40,7 @@
36
 
     {
37
 
         public static MeeGoPanel Instance { get; private set; }
38
 
 
39
 
-        private PanelGtk embedded_panel;
40
 
+        // private PanelGtk embedded_panel;
41
 
         private Window window_panel;
42
 
 
43
 
         public MediaPanelContents Contents { get; private set; }
44
 
@@ -55,25 +55,25 @@
45
 
 
46
 
             var timer = Log.DebugTimerStart ();
47
 
 
48
 
-            try {
49
 
-                Log.Debug ("Attempting to create Netbook toolbar panel");
50
 
-                embedded_panel = new PanelGtk ("banshee", Catalog.GetString ("media"),
51
 
-                    null, "media-button", true);
52
 
-                embedded_panel.ShowBeginEvent += (o, e) => {
53
 
-                    ServiceManager.SourceManager.SetActiveSource (ServiceManager.SourceManager.MusicLibrary);
54
 
-                    if (Contents != null) {
55
 
-                        Contents.SyncSearchEntry ();
56
 
-                    }
57
 
-                };
58
 
-                while (Gtk.Application.EventsPending ()) {
59
 
-                    Gtk.Application.RunIteration ();
60
 
-                }
61
 
-            } catch (Exception e) {
62
 
-                if (!(e is DllNotFoundException)) {
63
 
-                    Log.Exception ("Could not bind to Netbook panel", e);
64
 
-                }
65
 
+            // try {
66
 
+            //     Log.Debug ("Attempting to create Netbook toolbar panel");
67
 
+            //     embedded_panel = new PanelGtk ("banshee", Catalog.GetString ("media"),
68
 
+            //         null, "media-button", true);
69
 
+            //     embedded_panel.ShowBeginEvent += (o, e) => {
70
 
+            //         ServiceManager.SourceManager.SetActiveSource (ServiceManager.SourceManager.MusicLibrary);
71
 
+            //         if (Contents != null) {
72
 
+            //             Contents.SyncSearchEntry ();
73
 
+            //         }
74
 
+            //     };
75
 
+            //     while (Gtk.Application.EventsPending ()) {
76
 
+            //         Gtk.Application.RunIteration ();
77
 
+            //     }
78
 
+            // } catch (Exception e) {
79
 
+                // if (!(e is DllNotFoundException)) {
80
 
+                //     Log.Exception ("Could not bind to Netbook panel", e);
81
 
+                // }
82
 
                 window_panel = new Gtk.Window ("Netbook Media Panel");
83
 
-            }
84
 
+            // }
85
 
 
86
 
             Log.DebugTimerPrint (timer, "Netbook panel created: {0}");
87
 
         }
88
 
@@ -89,9 +89,10 @@
89
 
             Contents.ShowAll ();
90
 
             Log.DebugTimerPrint (timer, "Netbook panel contents created: {0}");
91
 
 
92
 
-            if (embedded_panel != null) {
93
 
-                embedded_panel.SetChild (Contents);
94
 
-            } else if (window_panel != null) {
95
 
+            // if (embedded_panel != null) {
96
 
+            //     embedded_panel.SetChild (Contents);
97
 
+            // } else if (window_panel != null) 
98
 
+            {
99
 
                 window_panel.Add (Contents);
100
 
                 window_panel.SetDefaultSize (1000, 500);
101
 
                 window_panel.WindowPosition = WindowPosition.Center;
102
 
@@ -106,17 +107,17 @@
103
 
         public void Hide ()
104
 
         {
105
 
             window_panel.Hide ();
106
 
-            if (embedded_panel != null) {
107
 
-                embedded_panel.Hide ();
108
 
-            }
109
 
+            // if (embedded_panel != null) {
110
 
+            //     embedded_panel.Hide ();
111
 
+            // }
112
 
         }
113
 
 
114
 
         public void Show ()
115
 
         {
116
 
             window_panel.Show ();
117
 
-            if (embedded_panel != null) {
118
 
-                embedded_panel.Show ();
119
 
-            }
120
 
+            // if (embedded_panel != null) {
121
 
+            //     embedded_panel.Show ();
122
 
+            // }
123
 
         }
124
 
     }
125
 
 }