~ubuntu-branches/ubuntu/utopic/nautilus/utopic-proposed

« back to all changes in this revision

Viewing changes to debian/patches/git_list_handlers.patch

  • Committer: Package Import Robot
  • Author(s): Tim Lunn
  • Date: 2014-01-02 16:50:06 UTC
  • mfrom: (1.17.43)
  • Revision ID: package-import@ubuntu.com-20140102165006-1ghk9ropzitdc8pp
Tags: 1:3.10.1-0ubuntu1
* New upstream release
* debian/control.in: bump depend on gtk+ 3.9.11
* debian/patches:
  - Dropped git patches, that are included in new version
  - 06_never_exec_nonexec_launchers.patch, refreshed
  - disconnect-extra-location-widgets.patch, dropped included in new version
  - 16_unity_new_documents.patch, refreshed
  - ubuntu_show_titlebar.patch, disable CSD titlebar on non-GNOME sessions
  - ubuntu_titlebar_css.patch, theme fixes (LP: #1272602)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 9a4ff3ca0d8476e15daa6dd92ac6c0eb8c5b9695 Mon Sep 17 00:00:00 2001
2
 
From: Cosimo Cecchi <cosimoc@gnome.org>
3
 
Date: Tue, 17 Sep 2013 17:59:37 +0000
4
 
Subject: Revert "mime-actions: filter applications not supposed to be visible"
5
 
 
6
 
This reverts commit 7770b63d6726bc7ab4b886d6bd3edd009e622e55.
7
 
 
8
 
https://bugzilla.gnome.org/show_bug.cgi?id=702681
9
 
---
10
 
diff --git a/src/nautilus-mime-actions.c b/src/nautilus-mime-actions.c
11
 
index ae9fa8a..401aa8c 100644
12
 
--- a/src/nautilus-mime-actions.c
13
 
+++ b/src/nautilus-mime-actions.c
14
 
@@ -258,28 +258,6 @@ filter_nautilus_handler (GList *apps)
15
 
 }
16
 
 
17
 
 static GList*
18
 
-filter_no_show_apps (GList *apps)
19
 
-{
20
 
-       GList *l, *next;
21
 
-       GAppInfo *application;
22
 
-
23
 
-       l = apps;
24
 
-       while (l != NULL) {
25
 
-               application = (GAppInfo *) l->data;
26
 
-               next = l->next;
27
 
-
28
 
-               if (!g_app_info_should_show (application)) {
29
 
-                       g_object_unref (application);
30
 
-                       apps = g_list_delete_link (apps, l);
31
 
-               }
32
 
-
33
 
-               l = next;
34
 
-       }
35
 
-
36
 
-       return apps;
37
 
-}
38
 
-
39
 
-static GList*
40
 
 filter_non_uri_apps (GList *apps,
41
 
                     gboolean accept_files)
42
 
 {
43
 
@@ -470,8 +448,6 @@ nautilus_mime_get_applications_for_file (NautilusFile *file)
44
 
                g_free (uri_scheme);
45
 
        }
46
 
 
47
 
-       result = filter_no_show_apps (result);
48
 
-
49
 
        /* Filter out non-uri supporting apps */
50
 
        result = filter_non_uri_apps (result, file_has_local_path (file));
51
 
 
52