~ubuntu-branches/ubuntu/utopic/nautilus/utopic-proposed

« back to all changes in this revision

Viewing changes to debian/patches/git_rtl_icons.patch

  • Committer: Package Import Robot
  • Author(s): Tim Lunn
  • Date: 2014-01-02 16:50:06 UTC
  • mfrom: (1.17.43)
  • Revision ID: package-import@ubuntu.com-20140102165006-1ghk9ropzitdc8pp
Tags: 1:3.10.1-0ubuntu1
* New upstream release
* debian/control.in: bump depend on gtk+ 3.9.11
* debian/patches:
  - Dropped git patches, that are included in new version
  - 06_never_exec_nonexec_launchers.patch, refreshed
  - disconnect-extra-location-widgets.patch, dropped included in new version
  - 16_unity_new_documents.patch, refreshed
  - ubuntu_show_titlebar.patch, disable CSD titlebar on non-GNOME sessions
  - ubuntu_titlebar_css.patch, theme fixes (LP: #1272602)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From e123ad58bbb26e9369d5b7573e538c0c2455da0f Mon Sep 17 00:00:00 2001
2
 
From: Yosef Or Boczko <yoseforb@gmail.com>
3
 
Date: Mon, 29 Jul 2013 15:44:14 +0000
4
 
Subject: toolbar: Set button arrow icons according to locale's text direction
5
 
 
6
 
https://bugzilla.gnome.org/show_bug.cgi?id=705072
7
 
---
8
 
diff --git a/src/nautilus-toolbar.c b/src/nautilus-toolbar.c
9
 
index 15575fd..9ef565b 100644
10
 
--- a/src/nautilus-toolbar.c
11
 
+++ b/src/nautilus-toolbar.c
12
 
@@ -408,9 +408,12 @@ nautilus_toolbar_constructed (GObject *obj)
13
 
        GtkToolItem *back_forward;
14
 
        GtkToolItem *tool_item;
15
 
        GtkUIManager *ui_manager;
16
 
+       gboolean rtl;
17
 
 
18
 
        G_OBJECT_CLASS (nautilus_toolbar_parent_class)->constructed (obj);
19
 
 
20
 
+       rtl = gtk_widget_get_default_direction () == GTK_TEXT_DIR_RTL;
21
 
+
22
 
        ui_manager = nautilus_window_get_ui_manager (self->priv->window);
23
 
 
24
 
        gtk_style_context_set_junction_sides (gtk_widget_get_style_context (GTK_WIDGET (self)),
25
 
@@ -433,11 +436,15 @@ nautilus_toolbar_constructed (GObject *obj)
26
 
 
27
 
        /* Back */
28
 
        tool_button = toolbar_create_toolbutton (self, FALSE, FALSE, NAUTILUS_ACTION_BACK, NULL);
29
 
+       gtk_action_set_icon_name (gtk_activatable_get_related_action (tool_button),
30
 
+                                 rtl ? "go-previous-rtl-symbolic" : "go-previous-symbolic");
31
 
        navigation_button_setup_menu (self, tool_button, NAUTILUS_NAVIGATION_DIRECTION_BACK);
32
 
        gtk_container_add (GTK_CONTAINER (box), GTK_WIDGET (tool_button));
33
 
 
34
 
        /* Forward */
35
 
        tool_button = toolbar_create_toolbutton (self, FALSE, FALSE, NAUTILUS_ACTION_FORWARD, NULL);
36
 
+       gtk_action_set_icon_name (gtk_activatable_get_related_action (tool_button),
37
 
+                                 rtl ? "go-next-rtl-symbolic" : "go-next-symbolic");
38
 
        navigation_button_setup_menu (self, tool_button, NAUTILUS_NAVIGATION_DIRECTION_FORWARD);
39
 
        gtk_container_add (GTK_CONTAINER (box), GTK_WIDGET (tool_button));
40
 
 
41
 
--
42
 
cgit v0.9.2
43