~ubuntu-branches/ubuntu/lucid/mc/lucid

« back to all changes in this revision

Viewing changes to debian/patches/32_c-vs-cxx.patch

  • Committer: Bazaar Package Importer
  • Author(s): Patrick Winnertz
  • Date: 2008-09-16 10:38:59 UTC
  • mfrom: (3.1.6 intrepid)
  • Revision ID: james.westby@ubuntu.com-20080916103859-2uwn8w61xk5mbxxq
Tags: 2:4.6.2~git20080311-4
Corrected fix for odt2txt issue (Closes: #492019) 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- syntax/Makefile.am  6 Dec 2004 23:14:43 -0000       1.22
2
 
+++ syntax/Makefile.am  20 Feb 2005 09:42:01 -0000
3
 
@@ -4,4 +4,5 @@
4
 
        aspx.syntax             \
5
 
        c.syntax                \
6
 
+       cxx.syntax              \
7
 
        cs.syntax               \
8
 
        changelog.syntax        \
9
 
--- syntax/Syntax       3 Nov 2004 20:16:48 -0000       1.27
10
 
+++ syntax/Syntax       20 Feb 2005 09:42:01 -0000
11
 
@@ -69,7 +69,10 @@
12
 
 include texinfo.syntax
13
 
 
14
 
-file ..\*\\.([chC]|CC|cxx|cc|cpp|CPP|CXX|hxx|h\.in)$ C/C\+\+\sProgram
15
 
+file ..\*\\.c$ C\sProgram
16
 
 include c.syntax
17
 
 
18
 
+file ..\*\\.([hC]|CC|cxx|cc|cpp|CPP|CXX|hxx|h\.in)$ C/C\+\+\sProgram
19
 
+include cxx.syntax
20
 
+
21
 
 file ..\*\\.[fF]$ Fortran\sProgram
22
 
 include fortran.syntax
23
 
--- syntax/c.syntax     15 Mar 2003 04:41:20 -0000      1.15
24
 
+++ syntax/c.syntax     20 Feb 2005 09:42:01 -0000
25
 
@@ -33,32 +33,5 @@
26
 
     keyword whole while yellow
27
 
     keyword whole asm yellow
28
 
-    keyword whole catch yellow
29
 
-    keyword whole class yellow
30
 
-    keyword whole friend yellow
31
 
-    keyword whole delete yellow
32
 
     keyword whole inline yellow
33
 
-    keyword whole new yellow
34
 
-    keyword whole operator yellow
35
 
-    keyword whole private yellow
36
 
-    keyword whole protected yellow
37
 
-    keyword whole public yellow
38
 
-    keyword whole this yellow
39
 
-    keyword whole throw yellow
40
 
-    keyword whole template yellow
41
 
-    keyword whole try yellow
42
 
-    keyword whole virtual yellow
43
 
-    keyword whole bool yellow
44
 
-    keyword whole const_cast yellow
45
 
-    keyword whole dynamic_cast yellow
46
 
-    keyword whole explicit yellow
47
 
-    keyword whole false yellow
48
 
-    keyword whole mutable yellow
49
 
-    keyword whole namespace yellow
50
 
-    keyword whole reinterpret_cast yellow
51
 
-    keyword whole static_cast yellow
52
 
-    keyword whole true yellow
53
 
-    keyword whole typeid yellow
54
 
-    keyword whole typename yellow
55
 
-    keyword whole using yellow
56
 
     keyword whole wchar_t yellow
57
 
     keyword whole ... yellow