~ubuntu-branches/ubuntu/natty/avant-window-navigator/natty

« back to all changes in this revision

Viewing changes to debian/patches/914-fix-vala-0.9-compatibility.patch

  • Committer: Bazaar Package Importer
  • Author(s): Julien Lavergne
  • Date: 2010-12-17 13:48:28 UTC
  • mfrom: (1.1.9 upstream)
  • Revision ID: james.westby@ubuntu.com-20101217134828-l394fb03wdkxc3mq
Tags: 0.4.1~bzr803-0ubuntu1
* New upstream snapshot.
 - Fix a crash with signal 5 in _XError (LP: #612144)
 - Re-add "move to another workspace" to launcher (LP: #568555)
* debian/patches:
 - 02-ftbfs-python-2.6.patch: Refresh.
 - 03-python-import.patch: Refresh.
 - 04-lda-requierement.patch: New patch, lower desktop-agnostic requierement,
   the version in Natty is enough.
 - Drop all others patches, merged upstream.
* debian/copyright:
 - Update copyright years and upstream authors.
* debian/control:
 - Build-depends on valac-0.10 (>= 0.9.1), to force stable version of Vala.
* debian/libawn1.symbols:
 - Update with new symbols. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- a/applets/quick-prefs/applet.vala
2
 
+++ b/applets/quick-prefs/applet.vala
3
 
@@ -47,9 +47,9 @@
4
 
 
5
 
   public PrefsApplet (string canonical_name, string uid, int panel_id)
6
 
   {
7
 
-    this.canonical_name = canonical_name;
8
 
-    this.uid = uid;
9
 
-    this.panel_id = panel_id;
10
 
+    GLib.Object (canonical_name: canonical_name,
11
 
+                 uid: uid,
12
 
+                 panel_id: panel_id);
13
 
   }
14
 
 
15
 
   construct
16
 
--- a/applets/taskmanager/dock-manager-api.vala
17
 
+++ b/applets/taskmanager/dock-manager-api.vala
18
 
@@ -66,7 +66,7 @@
19
 
     });
20
 
     */
21
 
 
22
 
-    var conn = Bus.get (BusType.SESSION);
23
 
+    var conn = DBus.Bus.get (DBus.BusType.SESSION);
24
 
     string obj_path = "/org/freedesktop/DockManager";
25
 
     conn.register_object (obj_path, this);
26
 
   }
27
 
@@ -244,7 +244,7 @@
28
 
   {
29
 
     this.icon = icon;
30
 
 
31
 
-    var conn = Bus.get (BusType.SESSION);
32
 
+    var conn = DBus.Bus.get (DBus.BusType.SESSION);
33
 
     this.object_path = "/org/freedesktop/DockManager/Item%d".printf (counter++);
34
 
     conn.register_object (this.object_path, this);
35