~ubuntu-branches/ubuntu/raring/wxwidgets2.8/raring

« back to all changes in this revision

Viewing changes to debian/patches/fix-wxcmdline-segv.patch

  • Committer: Package Import Robot
  • Author(s): Stéphane Graber
  • Date: 2012-01-07 13:59:25 UTC
  • mfrom: (1.1.9) (5.1.10 sid)
  • Revision ID: package-import@ubuntu.com-20120107135925-2601miy9ullcon9j
Tags: 2.8.12.1-6ubuntu1
* Resync from Debian, changes that were kept:
  - debian/rules: re-enable mediactrl. This allows libwx_gtk2u_media-2.8 to be
    built, as this is required by some applications (LP: #632984)
  - debian/control: Build-dep on libxt-dev for mediactrl.
  - Patches
    + fix-bashism-in-example
* Add conflict on python-wxgtk2.8 (<< 2.8.12.1-6ubuntu1~) to python-wxversion
  to guarantee upgrade ordering when moving from pycentral to dh_python2.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Fix segfault in wxCmdLineParser::GetUsageString()
 
2
Bug-Debian: 646654.
 
3
Author: Olly Betts <olly@survex.com>
 
4
Forwarded: http://trac.wxwidgets.org/ticket/13731
 
5
Last-Update: 2011-11-11
 
6
 
 
7
diff --git a/src/common/cmdline.cpp b/src/common/cmdline.cpp
 
8
index c7b135d..0a32c55 100644
 
9
--- a/src/common/cmdline.cpp
 
10
+++ b/src/common/cmdline.cpp
 
11
@@ -951,7 +951,7 @@ void wxCmdLineParser::Usage()
 
12
 wxString wxCmdLineParser::GetUsageString()
 
13
 {
 
14
     wxString appname;
 
15
-    if ( wxTheApp )
 
16
+    if ( wxTheApp && wxTheApp->argc > 0 )
 
17
     {
 
18
         appname = wxFileName(wxTheApp->argv[0]).GetFullName();
 
19
     }