~ubuntu-branches/ubuntu/wily/clamav/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/0018-llvm-don-t-use-system-libs.patch

  • Committer: Package Import Robot
  • Author(s): Scott Kitterman, Sebastian Andrzej Siewior, Andreas Cadhalpun, Scott Kitterman, Javier Fernández-Sanguino
  • Date: 2015-01-28 00:25:13 UTC
  • mfrom: (0.48.14 sid)
  • Revision ID: package-import@ubuntu.com-20150128002513-lil2oi74cooy4lzr
Tags: 0.98.6+dfsg-1
[ Sebastian Andrzej Siewior ]
* update "fix-ssize_t-size_t-off_t-printf-modifier", include of misc.h was
  missing but was pulled in via the systemd patch.
* Don't leak return codes from libmspack to clamav API. (Closes: #774686).

[ Andreas Cadhalpun ]
* Add patch to avoid emitting incremental progress messages when not
  outputting to a terminal. (Closes: #767350)
* Update lintian-overrides for unused-file-paragraph-in-dep5-copyright.
* clamav-base.postinst: always chown /var/log/clamav and /var/lib/clamav
  to clamav:clamav, not only on fresh installations. (Closes: #775400)
* Adapt the clamav-daemon and clamav-freshclam logrotate scripts,
  so that they correctly work under systemd.
* Move the PidFile variable from the clamd/freshclam configuration files
  to the init scripts. This makes the init scripts more robust against
  misconfiguration and avoids error messages with systemd. (Closes: #767353)
* debian/copyright: drop files from Files-Excluded only present in github
  tarballs
* Drop Workaround-a-bug-in-libc-on-Hurd.patch, because hurd got fixed.
  (see #752237)
* debian/rules: Remove useless --with-system-tommath --without-included-ltdl
  configure options.

[ Scott Kitterman ]
* Stop stripping llvm when repacking the tarball as the system llvm on some
  releases is too old to use
* New upstream bugfix release
  - Library shared object revisions.
  - Includes a patch from Sebastian Andrzej Siewior making ClamAV pid files
    compatible with systemd.
  - Fix a heap out of bounds condition with crafted Yoda's crypter files.
    This issue was discovered by Felix Groebert of the Google Security Team.
  - Fix a heap out of bounds condition with crafted mew packer files. This
    issue was discovered by Felix Groebert of the Google Security Team.
  - Fix a heap out of bounds condition with crafted upx packer files. This
    issue was discovered by Kevin Szkudlapski of Quarkslab.
  - Fix a heap out of bounds condition with crafted upack packer files. This
    issue was discovered by Sebastian Andrzej Siewior. CVE-2014-9328.
  - Compensate a crash due to incorrect compiler optimization when handling
    crafted petite packer files. This issue was discovered by Sebastian
    Andrzej Siewior.
* Update lintian override for embedded zlib to match new so version

[ Javier Fernández-Sanguino ]
* Updated Spanish Debconf template translation (Closes: #773563)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 169677f7699f78d483c84b4ab54943ea622535c8 Mon Sep 17 00:00:00 2001
2
 
From: Sebastian Andrzej Siewior <sebastian@breakpoint.cc>
3
 
Date: Wed, 19 Nov 2014 23:04:32 +0100
4
 
Subject: llvm: don't use --system-libs
5
 
 
6
 
this continues the saga of not linking the .a files so we don't care
7
 
about the libs llvm links against (like -ledit)
8
 
 
9
 
Signed-off-by: Sebastian Andrzej Siewior <sebastian@breakpoint.cc>
10
 
---
11
 
 libclamav/c++/configure.ac | 2 +-
12
 
 1 file changed, 1 insertion(+), 1 deletion(-)
13
 
 
14
 
diff --git a/libclamav/c++/configure.ac b/libclamav/c++/configure.ac
15
 
index 43e187ff1f56..2d2d47b9d24c 100644
16
 
--- a/libclamav/c++/configure.ac
17
 
+++ b/libclamav/c++/configure.ac
18
 
@@ -115,7 +115,7 @@ if test "x$llvmconfig" != "x"; then
19
 
     if test $llvmver_test -ge 350; then
20
 
         dnl LLVM 3.5.0 and after splits linker flags into two sets
21
 
         ldflags=`$llvmconfig --ldflags`
22
 
-        syslibs=`$llvmconfig --system-libs`
23
 
+        syslibs=
24
 
         AC_SUBST(LLVMCONFIG_LDFLAGS, ["$ldflags $syslibs"])
25
 
     else
26
 
         AC_SUBST(LLVMCONFIG_LDFLAGS, [`$llvmconfig --ldflags`])