~ubuntu-branches/ubuntu/raring/nautilus/raring

« back to all changes in this revision

Viewing changes to debian/patches/15_use-ubuntu-help.patch

  • Committer: Package Import Robot
  • Author(s): Sebastien Bacher, Jeremy Bicha
  • Date: 2012-01-31 13:45:01 UTC
  • mfrom: (1.17.25)
  • Revision ID: package-import@ubuntu.com-20120131134501-yn7mqny7fgzx9fao
Tags: 1:3.3.4-0ubuntu1
* New upstream version which fixes:
  - "Opening Popupmenu in Context of Folder with List-View impossible?"
    (lp: #126540)
  - "'Create folder in here' context menu option for nautilus" (lp: #61786)
  - the file count and the size count change in opposite direction.
    (lp: #503330)
  - the mounts in the place menu should have a properties entry.
    (lp: #846289)
  - add command line option to select file (lp: #575719)
  - Media in 'Places' side bar should have same context menu as in 
    'Computer' (lp: #230098)
* debian/nautilus-data.install:
  - updated, ui and icons have been moved into gresources
* debian/patches/05_desktop_menu_export.patch:
   - updated to correctly include the gresources desktop definition

[ Jeremy Bicha ]
* New upstream release.
* debian/control.in:
  - Bump minimum GTK and glib
* Refreshed patches
* Dropped upstream patches:
  - 17_dont_allow_new_tab_on_desktop.patch
  - 18_fix_crash_in_get_current_uri.patch
  - 19_lazily_initialize_notification_service.patch
  - git_sideplace_sorting.patch
  - git_next_row.patch
  - git_dont_document_browser_option.patch
  - git_browser_compat.patch
  - git_bookmarks_reordering.patch
  - git_listview_context_menus.patch
  - git_use_gtk_grid.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
2
2
Forwarded: Not needed
3
3
Author: Jeremy Bicha <jbicha@ubuntu.com>
4
4
 
5
 
Index: nautilus-3.2.1/src/nautilus-bookmarks-window.c
 
5
Index: nautilus-3.3.4/src/nautilus-bookmarks-window.c
6
6
===================================================================
7
 
--- nautilus-3.2.1.orig/src/nautilus-bookmarks-window.c 2011-09-21 20:11:33.000000000 +0200
8
 
+++ nautilus-3.2.1/src/nautilus-bookmarks-window.c      2011-12-16 12:37:23.968145175 +0100
9
 
@@ -145,7 +145,7 @@
 
7
--- nautilus-3.3.4.orig/src/nautilus-bookmarks-window.c 2012-01-29 11:12:16.209337577 -0500
 
8
+++ nautilus-3.3.4/src/nautilus-bookmarks-window.c      2012-01-29 11:12:56.549537609 -0500
 
9
@@ -146,7 +146,7 @@
10
10
                GError *error = NULL;
11
11
 
12
12
                gtk_show_uri (gtk_window_get_screen (GTK_WINDOW (dialog)),
15
15
                              gtk_get_current_event_time (), &error);
16
16
 
17
17
                if (error) {
18
 
Index: nautilus-3.2.1/src/nautilus-connect-server-dialog.c
 
18
Index: nautilus-3.3.4/src/nautilus-connect-server-dialog.c
19
19
===================================================================
20
 
--- nautilus-3.2.1.orig/src/nautilus-connect-server-dialog.c    2011-10-17 22:29:15.000000000 +0200
21
 
+++ nautilus-3.2.1/src/nautilus-connect-server-dialog.c 2011-12-16 12:37:23.972145174 +0100
 
20
--- nautilus-3.3.4.orig/src/nautilus-connect-server-dialog.c    2012-01-29 11:12:16.181337438 -0500
 
21
+++ nautilus-3.3.4/src/nautilus-connect-server-dialog.c 2012-01-29 11:12:56.549537609 -0500
22
22
@@ -695,7 +695,7 @@
23
23
        case GTK_RESPONSE_HELP :
24
24
                error = NULL;
28
28
                              gtk_get_current_event_time (), &error);
29
29
                if (error) {
30
30
                        eel_show_error_dialog (_("There was an error displaying help."), error->message,
31
 
Index: nautilus-3.2.1/src/nautilus-file-management-properties.c
 
31
Index: nautilus-3.3.4/src/nautilus-file-management-properties.c
32
32
===================================================================
33
 
--- nautilus-3.2.1.orig/src/nautilus-file-management-properties.c       2011-09-26 16:18:22.000000000 +0200
34
 
+++ nautilus-3.2.1/src/nautilus-file-management-properties.c    2011-12-16 12:37:23.972145174 +0100
 
33
--- nautilus-3.3.4.orig/src/nautilus-file-management-properties.c       2012-01-29 11:12:16.249337771 -0500
 
34
+++ nautilus-3.3.4/src/nautilus-file-management-properties.c    2012-01-29 11:12:56.549537609 -0500
35
35
@@ -239,7 +239,7 @@
36
36
                        section = "nautilus-preview";
37
37
                        break;
41
41
        } else if (response_id == GTK_RESPONSE_CLOSE) {
42
42
                gtk_widget_destroy (GTK_WIDGET (parent));
43
43
        }
44
 
Index: nautilus-3.2.1/src/nautilus-properties-window.c
 
44
Index: nautilus-3.3.4/src/nautilus-properties-window.c
45
45
===================================================================
46
 
--- nautilus-3.2.1.orig/src/nautilus-properties-window.c        2011-10-17 22:29:15.000000000 +0200
47
 
+++ nautilus-3.2.1/src/nautilus-properties-window.c     2011-12-16 12:37:23.980145178 +0100
48
 
@@ -3050,7 +3050,7 @@
49
 
        guint last_row, row;
 
46
--- nautilus-3.3.4.orig/src/nautilus-properties-window.c        2012-01-29 11:12:16.173337390 -0500
 
47
+++ nautilus-3.3.4/src/nautilus-properties-window.c     2012-01-29 11:12:56.553537627 -0500
 
48
@@ -3020,7 +3020,7 @@
 
49
        GtkWidget *hbox, *vbox;
50
50
 
51
51
        hbox = create_page_with_hbox (window->details->notebook, _("Basic"),
52
52
-                                     "help:gnome-help/nautilus-file-properties-basic");
54
54
        
55
55
        /* Icon pixmap */
56
56
 
57
 
@@ -4532,7 +4532,7 @@
 
57
@@ -4465,7 +4465,7 @@
58
58
 
59
59
        vbox = create_page_with_vbox (window->details->notebook,
60
60
                                      _("Permissions"),
63
63
 
64
64
        file_list = window->details->original_files;
65
65
 
66
 
@@ -4830,7 +4830,7 @@
 
66
@@ -4759,7 +4759,7 @@
67
67
        gtk_widget_show (vbox);
68
68
        g_free (mime_type);
69
69
 
72
72
        gtk_notebook_append_page (window->details->notebook, 
73
73
                                  vbox, gtk_label_new (_("Open With")));
74
74
 }
75
 
@@ -5171,7 +5171,7 @@
 
75
@@ -5115,7 +5115,7 @@
76
76
                                                     gtk_notebook_get_current_page (window->details->notebook));
77
77
                helpuri = g_object_get_data (G_OBJECT (curpage), "help-uri");
78
78
                gtk_show_uri (gtk_window_get_screen (GTK_WINDOW (dialog)),
81
81
                              gtk_get_current_event_time (),
82
82
                              &error);
83
83
                if (error != NULL) {
84
 
Index: nautilus-3.2.1/src/nautilus-view.c
 
84
Index: nautilus-3.3.4/src/nautilus-view.c
85
85
===================================================================
86
 
--- nautilus-3.2.1.orig/src/nautilus-view.c     2011-12-16 12:37:23.224145204 +0100
87
 
+++ nautilus-3.2.1/src/nautilus-view.c  2011-12-16 12:37:23.988145179 +0100
88
 
@@ -1533,7 +1533,7 @@
 
86
--- nautilus-3.3.4.orig/src/nautilus-view.c     2012-01-29 11:12:54.593527918 -0500
 
87
+++ nautilus-3.3.4/src/nautilus-view.c  2012-01-29 11:12:56.553537627 -0500
 
88
@@ -1459,7 +1459,7 @@
89
89
        case GTK_RESPONSE_HELP :
90
90
                error = NULL;
91
91
                gtk_show_uri (gtk_window_get_screen (GTK_WINDOW (dialog)),
94
94
                              gtk_get_current_event_time (), &error);
95
95
                if (error) {
96
96
                        eel_show_error_dialog (_("There was an error displaying help."), error->message,
97
 
Index: nautilus-3.2.1/src/nautilus-window-menus.c
 
97
Index: nautilus-3.3.4/src/nautilus-window-menus.c
98
98
===================================================================
99
 
--- nautilus-3.2.1.orig/src/nautilus-window-menus.c     2011-12-16 12:37:13.184145559 +0100
100
 
+++ nautilus-3.2.1/src/nautilus-window-menus.c  2011-12-16 12:37:23.992145179 +0100
 
99
--- nautilus-3.3.4.orig/src/nautilus-window-menus.c     2012-01-29 11:12:28.861400307 -0500
 
100
+++ nautilus-3.3.4/src/nautilus-window-menus.c  2012-01-29 11:12:56.557537647 -0500
101
101
@@ -430,19 +430,19 @@
102
102
        window = NAUTILUS_WINDOW (user_data);
103
103