~ubuntu-branches/ubuntu/raring/nautilus/raring

« back to all changes in this revision

Viewing changes to debian/patches/18_fix_crash_in_get_current_uri.patch

  • Committer: Package Import Robot
  • Author(s): Sebastien Bacher, Jeremy Bicha
  • Date: 2012-01-31 13:45:01 UTC
  • mfrom: (1.17.25)
  • Revision ID: package-import@ubuntu.com-20120131134501-yn7mqny7fgzx9fao
Tags: 1:3.3.4-0ubuntu1
* New upstream version which fixes:
  - "Opening Popupmenu in Context of Folder with List-View impossible?"
    (lp: #126540)
  - "'Create folder in here' context menu option for nautilus" (lp: #61786)
  - the file count and the size count change in opposite direction.
    (lp: #503330)
  - the mounts in the place menu should have a properties entry.
    (lp: #846289)
  - add command line option to select file (lp: #575719)
  - Media in 'Places' side bar should have same context menu as in 
    'Computer' (lp: #230098)
* debian/nautilus-data.install:
  - updated, ui and icons have been moved into gresources
* debian/patches/05_desktop_menu_export.patch:
   - updated to correctly include the gresources desktop definition

[ Jeremy Bicha ]
* New upstream release.
* debian/control.in:
  - Bump minimum GTK and glib
* Refreshed patches
* Dropped upstream patches:
  - 17_dont_allow_new_tab_on_desktop.patch
  - 18_fix_crash_in_get_current_uri.patch
  - 19_lazily_initialize_notification_service.patch
  - git_sideplace_sorting.patch
  - git_next_row.patch
  - git_dont_document_browser_option.patch
  - git_browser_compat.patch
  - git_bookmarks_reordering.patch
  - git_listview_context_menus.patch
  - git_use_gtk_grid.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Fix crash in nautilus_window_slot_get_current_uri()
2
 
Author: Cosimo Cecchi <cosimoc@gnome.org>
3
 
Bug: https://bugzilla.gnome.org/show_bug.cgi?id=652320
4
 
Bug-Ubuntu: https://bugs.launchpad.net/bugs/795708
5
 
 
6
 
Index: nautilus-3.2.1/src/nautilus-window.c
7
 
===================================================================
8
 
--- nautilus-3.2.1.orig/src/nautilus-window.c   2011-12-16 12:37:17.352145410 +0100
9
 
+++ nautilus-3.2.1/src/nautilus-window.c        2011-12-16 12:37:26.288145095 +0100
10
 
@@ -474,8 +474,10 @@
11
 
 {
12
 
        DEBUG ("Destroying sidebar");
13
 
 
14
 
-       gtk_widget_destroy (GTK_WIDGET (window->details->sidebar));
15
 
-       window->details->sidebar = NULL;
16
 
+       if (window->details->sidebar != NULL) {
17
 
+               gtk_widget_destroy (GTK_WIDGET (window->details->sidebar));
18
 
+               window->details->sidebar = NULL;
19
 
+       }
20
 
 }
21
 
 
22
 
 void
23
 
@@ -721,8 +723,8 @@
24
 
 
25
 
        DEBUG ("Destroying window");
26
 
 
27
 
-       window->details->content_paned = NULL;
28
 
-       window->details->split_view_hpane = NULL;
29
 
+       /* close the sidebar first */
30
 
+       nautilus_window_tear_down_sidebar (window);
31
 
 
32
 
        /* close all panes safely */
33
 
        panes_copy = g_list_copy (window->details->panes);