~ubuntu-branches/ubuntu/raring/nautilus/raring

« back to all changes in this revision

Viewing changes to debian/patches/git_bookmarks_reordering.patch

  • Committer: Package Import Robot
  • Author(s): Sebastien Bacher, Jeremy Bicha
  • Date: 2012-01-31 13:45:01 UTC
  • mfrom: (1.17.25)
  • Revision ID: package-import@ubuntu.com-20120131134501-yn7mqny7fgzx9fao
Tags: 1:3.3.4-0ubuntu1
* New upstream version which fixes:
  - "Opening Popupmenu in Context of Folder with List-View impossible?"
    (lp: #126540)
  - "'Create folder in here' context menu option for nautilus" (lp: #61786)
  - the file count and the size count change in opposite direction.
    (lp: #503330)
  - the mounts in the place menu should have a properties entry.
    (lp: #846289)
  - add command line option to select file (lp: #575719)
  - Media in 'Places' side bar should have same context menu as in 
    'Computer' (lp: #230098)
* debian/nautilus-data.install:
  - updated, ui and icons have been moved into gresources
* debian/patches/05_desktop_menu_export.patch:
   - updated to correctly include the gresources desktop definition

[ Jeremy Bicha ]
* New upstream release.
* debian/control.in:
  - Bump minimum GTK and glib
* Refreshed patches
* Dropped upstream patches:
  - 17_dont_allow_new_tab_on_desktop.patch
  - 18_fix_crash_in_get_current_uri.patch
  - 19_lazily_initialize_notification_service.patch
  - git_sideplace_sorting.patch
  - git_next_row.patch
  - git_dont_document_browser_option.patch
  - git_browser_compat.patch
  - git_bookmarks_reordering.patch
  - git_listview_context_menus.patch
  - git_use_gtk_grid.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Subject: places-sidebar: don't assert we have a valid selected iter
2
 
 
3
 
When reordering bookmarks, don't assert we have a selected iter, since
4
 
it might not always be the case.
5
 
 
6
 
https://bugzilla.gnome.org/show_bug.cgi?id=660876
7
 
 
8
 
Subject: places-sidebar: return if we fail to compute a drop position
9
 
 
10
 
Instead of using an invalid GtkTreePath, which could cause a segfault
11
 
later.
12
 
 
13
 
https://bugzilla.gnome.org/show_bug.cgi?id=660876
14
 
 
15
 
Index: nautilus-3.2.1/src/nautilus-places-sidebar.c
16
 
===================================================================
17
 
--- nautilus-3.2.1.orig/src/nautilus-places-sidebar.c   2011-12-16 12:37:27.668145046 +0100
18
 
+++ nautilus-3.2.1/src/nautilus-places-sidebar.c        2011-12-16 12:37:30.692144939 +0100
19
 
@@ -1378,9 +1378,9 @@
20
 
        int old_position;
21
 
 
22
 
        /* Get the selected path */
23
 
-
24
 
-       if (!get_selected_iter (sidebar, &iter))
25
 
-               g_assert_not_reached ();
26
 
+       if (!get_selected_iter (sidebar, &iter)) {
27
 
+               return;
28
 
+       }
29
 
 
30
 
        gtk_tree_model_get (GTK_TREE_MODEL (sidebar->filter_model), &iter,
31
 
                            PLACES_SIDEBAR_COLUMN_ROW_TYPE, &type,
32
 
@@ -1439,7 +1439,10 @@
33
 
        }
34
 
 
35
 
        /* Compute position */
36
 
-       compute_drop_position (tree_view, x, y, &tree_path, &tree_pos, sidebar);
37
 
+       success = compute_drop_position (tree_view, x, y, &tree_path, &tree_pos, sidebar);
38
 
+       if (!success) {
39
 
+               goto out;
40
 
+       }
41
 
 
42
 
        success = FALSE;
43