~xav0989/ubuntu/vivid/mailman/ubuntu-logo

« back to all changes in this revision

Viewing changes to debian/patches/53_disable_addons.patch

  • Committer: Bazaar Package Importer
  • Author(s): Thijs Kinkhorst
  • Date: 2008-04-24 19:30:49 UTC
  • mfrom: (1.1.3 upstream)
  • Revision ID: james.westby@ubuntu.com-20080424193049-jy5fa9tus40tjbmn
Tags: 1:2.1.10-2
Apply upstream patch to fix regression in cmd_subscribe
so that email subscribe to the -subscribe or -join address or the
-request address with a bare 'subscribe' command results in the message
being shunted.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Patch: 53_disable_addons.patch
2
2
Author: Tollef Fog Heen <tfheen@debian.org>
3
3
Disable some modules which are pulled in from other Debian packages.
4
 
Index: misc/Makefile.in
5
 
===================================================================
6
 
--- misc/Makefile.in.orig       2006-08-15 15:12:18.000000000 +0800
7
 
+++ misc/Makefile.in    2006-08-15 15:14:39.000000000 +0800
 
4
diff -Nur misc/Makefile.in mailman-2.1.10b3/misc/Makefile.in
 
5
--- misc/Makefile.in    2008-02-02 23:29:26.000000000 +0100
 
6
+++ misc/Makefile.in    2008-02-08 23:19:31.000000000 +0100
8
7
@@ -57,7 +57,10 @@
9
8
 JACODECSPKG=   JapaneseCodecs-1.4.11
10
9
 KOCODECSPKG=   KoreanCodecs-2.0.5
17
16
 
18
17
 # Modes for directories and executables created by the install
19
18
 # process.  Default to group-writable directories but
20
 
Index: misc/paths.py.in
21
 
===================================================================
22
 
--- misc/paths.py.in.orig       2006-08-15 15:12:18.000000000 +0800
23
 
+++ misc/paths.py.in    2006-08-15 15:14:39.000000000 +0800
24
 
@@ -53,12 +53,18 @@
25
 
 # In a normal interactive Python environment, the japanese.pth and korean.pth
 
19
diff -Nur misc/paths.py.in mailman-2.1.10b3/misc/paths.py.in
 
20
--- misc/paths.py.in    2008-02-02 23:29:26.000000000 +0100
 
21
+++ misc/paths.py.in    2008-02-08 23:21:01.000000000 +0100
 
22
@@ -71,13 +71,19 @@
26
23
 # files would be imported automatically.  But because we inhibit the importing
27
24
 # of the site module, we need to be explicit about importing these codecs.
28
 
-import japanese
29
 
+try:
30
 
+    import japanese
31
 
+except ImportError:
32
 
+    pass
 
25
 if not jaok:
 
26
-    import japanese
 
27
+    try:
 
28
+        import japanese
 
29
+    except ImportError:
 
30
+        pass
33
31
 # As of KoreanCodecs 2.0.5, you had to do the second import to get the Korean
34
32
 # codecs installed, however leave the first import in there in case an upgrade
35
33
 # changes this.
36
 
-import korean
37
 
-import korean.aliases
38
 
+try:
39
 
+    import korean
40
 
+    import korean.aliases
41
 
+except ImportError:
42
 
+    pass
 
34
 if not kook:
 
35
-    import korean
 
36
-    import korean.aliases
 
37
+    try:
 
38
+        import korean
 
39
+        import korean.aliases
 
40
+    except ImportError:
 
41
+        pass
43
42
 # Arabic and Hebrew (RFC-1556) encoding aliases. (temporary solution)
44
43
 import encodings.aliases
45
44
 encodings.aliases.aliases.update({