~ubuntu-branches/debian/sid/mplayer/sid

« back to all changes in this revision

Viewing changes to debian/patches/demux.patch

  • Committer: Bazaar Package Importer
  • Author(s): A Mennucc1
  • Date: 2009-03-23 10:05:45 UTC
  • mfrom: (4.1.4 sid)
  • Revision ID: james.westby@ubuntu.com-20090323100545-x8h79obawnnte7kk
Tags: 1.0~rc2+svn20090303-5
debian/control : move docbook-xml,docbook-xsl,xsltproc from 
Build-Depends-Indep to Build-Depends, since they are needed to run
configure

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
##  by  Ondrej Certik
3
 
##
4
 
## DP: demux for newer ffmpeg  0.svn20080206
5
 
 
6
 
@DPATCH@
7
 
Index: mplayer-1.0~rc2/libmpdemux/demux_lavf.c
8
 
===================================================================
9
 
--- mplayer-1.0~rc2.orig/libmpdemux/demux_lavf.c        2008-07-05 12:41:23.000000000 +0200
10
 
+++ mplayer-1.0~rc2/libmpdemux/demux_lavf.c     2008-07-05 12:41:36.000000000 +0200
11
 
@@ -61,7 +61,7 @@
12
 
 typedef struct lavf_priv_t{
13
 
     AVInputFormat *avif;
14
 
     AVFormatContext *avfc;
15
 
-    ByteIOContext pb;
16
 
+    ByteIOContext *pb;
17
 
     int audio_streams;
18
 
     int video_streams;
19
 
     int sub_streams;
20
 
@@ -288,9 +288,9 @@
21
 
     
22
 
     url_fopen(&priv->pb, mp_filename, URL_RDONLY);
23
 
     
24
 
-    ((URLContext*)(priv->pb.opaque))->priv_data= demuxer->stream;
25
 
+    ((URLContext*)(priv->pb->opaque))->priv_data= demuxer->stream;
26
 
         
27
 
-    if(av_open_input_stream(&avfc, &priv->pb, mp_filename, priv->avif, &ap)<0){
28
 
+    if(av_open_input_stream(&avfc, priv->pb, mp_filename, priv->avif, &ap)<0){
29
 
         mp_msg(MSGT_HEADER,MSGL_ERR,"LAVF_header: av_open_input_stream() failed\n");
30
 
         return NULL;
31
 
     }
32
 
Index: mplayer-1.0~rc2/libmpdemux/muxer_lavf.c
33
 
===================================================================
34
 
--- mplayer-1.0~rc2.orig/libmpdemux/muxer_lavf.c        2008-07-05 12:41:31.000000000 +0200
35
 
+++ mplayer-1.0~rc2/libmpdemux/muxer_lavf.c     2008-07-05 12:41:36.000000000 +0200
36
 
@@ -40,7 +40,7 @@
37
 
 typedef struct {
38
 
        //AVInputFormat *avif;
39
 
        AVFormatContext *oc;
40
 
-       ByteIOContext pb;
41
 
+       ByteIOContext *pb;
42
 
        int audio_streams;
43
 
        int video_streams;
44
 
        int64_t last_pts;
45
 
@@ -317,7 +317,7 @@
46
 
                av_freep(&(priv->oc->streams[i]));
47
 
        }
48
 
 
49
 
-       url_fclose(&(priv->oc->pb));
50
 
+       url_fclose(priv->oc->pb);
51
 
 
52
 
        av_free(priv->oc);
53
 
 }