~ubuntu-branches/ubuntu/hardy/foxyproxy/hardy-updates

« back to all changes in this revision

Viewing changes to debian/patches/00_build_paths.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Sasa Bodiroza
  • Date: 2008-04-09 13:55:00 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20080409135500-x7u28czocbidxpmg
Tags: 2.7.2-0ubuntu1
* New upstream release. (LP: #212875)
* Improved packaging to make use of xpi.mk
* debian/control: 
  - Updated Maintainer field according to DebianMaintainerField spec
  - s/IceWeasel/Firefox/ in description
* debian/copyright: 
  - Updated copyright years
  - Updated packaging copyright
  - Added notice about xpi.mk packaging
  - Getting the source differs for this upload, added notice
* install.rdf: Bumped maxVersion to 3.0.*

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 00_build_paths.dpatch by Yaroslav Halchenko <debian@onerussian.com>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: No description.
6
 
 
7
 
@DPATCH@
8
 
diff -urNad foxyproxy-2.5.3~dfsg.1~/build.xml foxyproxy-2.5.3~dfsg.1/build.xml
9
 
--- foxyproxy-2.5.3~dfsg.1~/build.xml   2007-07-03 17:58:39.000000000 -0400
10
 
+++ foxyproxy-2.5.3~dfsg.1/build.xml    2007-07-03 17:58:54.000000000 -0400
11
 
@@ -22,12 +22,10 @@
12
 
   ALL RIGHTS RESERVED. U.S. PATENT PENDING.
13
 
 -->
14
 
 
15
 
-<project name="foxyproxy" default="build" basedir="/temp/fp-temp">
16
 
+<project name="foxyproxy" default="build" basedir="/tmp/fp-temp">
17
 
 
18
 
   <!-- version property is appended to XPI filename; e.g., foxyproxy-1.0.xpi -->
19
 
   <property name="version" value="2.5.3" />
20
 
-  <property name="temp-path" value="/temp/fp-temp" />
21
 
-  <property name="src-base" value="/dev/foxyproxy/standard/fx+flock/trunk/src"/>
22
 
   
23
 
 
24
 
   <!-- guid -->
25
 
@@ -50,13 +48,9 @@
26
 
   </target>
27
 
 
28
 
   <!-- create foxyproxy-x.y.z.xpi in the current dir using install.rdf in the current dir -->
29
 
+  <!-- yoh: xpi is not created for Debian -->
30
 
   <target name="build-unsigned">
31
 
     <move file="chrome.manifest.packaging" tofile="chrome.manifest" />
32
 
-    <zip destfile="${src-base}/foxyproxy-${version}-unsigned.xpi">
33
 
-      <fileset dir="${temp-path}" includes="chrome.manifest install.rdf LICENSE chrome/" />
34
 
-      <zipfileset dir="${temp-path}/components" prefix="components" includes="**/**" />
35
 
-      <zipfileset dir="${temp-path}/defaults" prefix="defaults" includes="**/**" />
36
 
-    </zip>
37
 
   </target>
38
 
 
39
 
   <target name="clean">
40
 
@@ -64,5 +58,5 @@
41
 
     <mkdir dir="${temp-path}" />
42
 
   </target>
43
 
   
44
 
-  <target name="build" depends="copy,jar,build-unsigned,clean" />
45
 
+  <target name="build" depends="copy,jar,build-unsigned" />
46
 
 </project>