~ubuntu-branches/ubuntu/lucid/blender/lucid

« back to all changes in this revision

Viewing changes to debian/patches/70_portability_platform_detection

  • Committer: Bazaar Package Importer
  • Author(s): Chris Coulson
  • Date: 2009-08-06 22:32:19 UTC
  • mfrom: (1.2.10 upstream)
  • Revision ID: james.westby@ubuntu.com-20090806223219-8z4eej1u8levu4pz
Tags: 2.49a+dfsg-0ubuntu1
* Merge from debian unstable, remaining changes:
  - debian/control: Build-depend on python-2.6 rather than python-2.5.
  - debian/misc/*.desktop: Add Spanish translation to .desktop 
    files.
  - debian/pyversions: 2.6.
  - debian/rules: Clean *.o of source/blender/python/api2_2x/
* New upstream release (LP: #382153).
* Refreshed patches:
  - 01_sanitize_sys.patch
  - 02_tmp_in_HOME
  - 10_use_systemwide_ftgl
  - 70_portability_platform_detection
* Removed patches merged upstream:
  - 30_fix_python_syntax_warning
  - 90_ubuntu_ffmpeg_52_changes

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- a/extern/bullet2/src/SConscript
2
 
+++ b/extern/bullet2/src/SConscript
 
1
Index: blender-2.49a+dfsg/extern/bullet2/src/SConscript
 
2
===================================================================
 
3
--- blender-2.49a+dfsg.orig/extern/bullet2/src/SConscript       2009-04-06 01:26:58.000000000 +0100
 
4
+++ blender-2.49a+dfsg/extern/bullet2/src/SConscript    2009-08-06 22:47:16.000000000 +0100
3
5
@@ -14,7 +14,7 @@
4
6
 elif env['OURPLATFORM']=='win32-mingw':
5
7
     defs += ' NDEBUG'
9
11
     defs += ' NDEBUG'
10
12
     cflags += ['-O2']
11
13
 elif sys.platform=='darwin':
12
 
--- a/extern/qhull/SConscript
13
 
+++ b/extern/qhull/SConscript
 
14
Index: blender-2.49a+dfsg/extern/qhull/SConscript
 
15
===================================================================
 
16
--- blender-2.49a+dfsg.orig/extern/qhull/SConscript     2007-05-15 16:25:27.000000000 +0100
 
17
+++ blender-2.49a+dfsg/extern/qhull/SConscript  2009-08-06 22:47:16.000000000 +0100
14
18
@@ -5,7 +5,7 @@
15
19
 Import('env')
16
20
 defs = ''
20
24
    cflags += ['-O2','-ansi']
21
25
 elif env['OURPLATFORM']=='win32-vc':
22
26
    cflags += ['/O2']
23
 
--- a/extern/solid/SConscript
24
 
+++ b/extern/solid/SConscript
 
27
Index: blender-2.49a+dfsg/extern/solid/SConscript
 
28
===================================================================
 
29
--- blender-2.49a+dfsg.orig/extern/solid/SConscript     2007-05-15 16:25:39.000000000 +0100
 
30
+++ blender-2.49a+dfsg/extern/solid/SConscript  2009-08-06 22:47:16.000000000 +0100
25
31
@@ -12,7 +12,7 @@
26
32
 elif env['OURPLATFORM']=='win32-mingw':
27
33
     defs += ' NDEBUG'
31
37
     defs += ' NDEBUG'
32
38
     cflags += ['-O2']
33
39
 elif sys.platform=='darwin' :
34
 
--- a/config/linux2-config.py
35
 
+++ b/config/linux2-config.py
36
 
@@ -137,8 +137,11 @@
 
40
Index: blender-2.49a+dfsg/config/linux2-config.py
 
41
===================================================================
 
42
--- blender-2.49a+dfsg.orig/config/linux2-config.py     2009-08-06 22:47:15.000000000 +0100
 
43
+++ blender-2.49a+dfsg/config/linux2-config.py  2009-08-06 22:47:16.000000000 +0100
 
44
@@ -169,8 +169,11 @@
37
45
 
38
 
 BF_FFMPEG_LIB = commands.getoutput('pkg-config --libs libavformat vorbisenc libswscale') + ' -lgsm'
 
46
 BF_FFMPEG_LIB = commands.getoutput('pkg-config --libs libavcodec libavformat vorbisenc libswscale libavdevice') + ' -lgsm' + ' -lopenjpeg'
39
47
 
40
48
+# Note: While linux2* and gnukfreebsd* share a lot, that particular case is
41
49
+# really Linux-specific, which is why there's not test on sys.platform starting
46
54
     BF_FFMPEG_LIB += ' ' + commands.getoutput('pkg-config --libs libdc1394-2')
47
55
 
48
56
 # Mesa Libs should go here if your using them as well....
49
 
--- a/SConstruct
50
 
+++ b/SConstruct
51
 
@@ -143,6 +143,13 @@
 
57
Index: blender-2.49a+dfsg/SConstruct
 
58
===================================================================
 
59
--- blender-2.49a+dfsg.orig/SConstruct  2009-06-18 19:53:45.000000000 +0100
 
60
+++ blender-2.49a+dfsg/SConstruct       2009-08-06 22:47:16.000000000 +0100
 
61
@@ -146,6 +146,13 @@
52
62
 
53
63
 env['OURPLATFORM'] = platform
54
64
 
62
72
 configfile = 'config'+os.sep+platform+'-config.py'
63
73
 
64
74
 if os.path.exists(configfile):
65
 
@@ -215,7 +222,7 @@
66
 
         """
 
75
@@ -222,7 +229,7 @@
 
76
                """
67
77
 
68
 
         def CheckFreeAlut(context,env):
69
 
-            context.Message( B.bc.OKGREEN + "Linux platform detected:\n  checking for FreeAlut... " + B.bc.ENDC )
70
 
+            context.Message( B.bc.OKGREEN + "Linux(-like) platform detected:\n  checking for FreeAlut... " + B.bc.ENDC )
71
 
             env['LIBS'] = 'alut'
72
 
             result = context.TryLink(mylib_test_source_file, '.c')
73
 
             context.Result(result)
74
 
--- a/release/scripts/bpymodules/colladaImEx/cutils.py
75
 
+++ b/release/scripts/bpymodules/colladaImEx/cutils.py
76
 
@@ -244,7 +244,7 @@
 
78
                def CheckFreeAlut(context,env):
 
79
-                       context.Message( B.bc.OKGREEN + "Linux platform detected:\n  checking for FreeAlut... " + B.bc.ENDC )
 
80
+                       context.Message( B.bc.OKGREEN + "Linux(-like) platform detected:\n  checking for FreeAlut... " + B.bc.ENDC )
 
81
                        env['LIBS'] = 'alut'
 
82
                        result = context.TryLink(mylib_test_source_file, '.c')
 
83
                        context.Result(result)
 
84
Index: blender-2.49a+dfsg/release/scripts/bpymodules/colladaImEx/cutils.py
 
85
===================================================================
 
86
--- blender-2.49a+dfsg.orig/release/scripts/bpymodules/colladaImEx/cutils.py    2009-05-25 17:46:08.000000000 +0100
 
87
+++ blender-2.49a+dfsg/release/scripts/bpymodules/colladaImEx/cutils.py 2009-08-06 22:47:16.000000000 +0100
 
88
@@ -289,7 +289,7 @@
77
89
 
78
90
 # Clear the console
79
91
 def ClearConsole():