~ubuntu-branches/ubuntu/lucid/sawfish/lucid-updates

« back to all changes in this revision

Viewing changes to debian/patches/02_makefile.in.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Christian Marillat
  • Date: 2005-02-23 16:16:46 UTC
  • mfrom: (1.2.1 upstream) (2.1.2 hoary)
  • Revision ID: james.westby@ubuntu.com-20050223161646-4id6qyw4h9lkvb0v
Tags: 1:1.3+cvs20050222-1
* New cvs release.
* Add an emacs initialisation script to load sawfish.el (Closes: #295290)
* Updated sawfish.el to 1.32

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh -e
 
2
 
 
3
# DP: Debian hack
 
4
 
 
5
if [ $# -ne 1 ]; then
 
6
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
7
    exit 1
 
8
fi
 
9
case "$1" in
 
10
       -patch) patch -f --no-backup-if-mismatch -p0 < $0;;
 
11
       -unpatch) patch -f --no-backup-if-mismatch -R -p0 < $0;;
 
12
        *)
 
13
                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
14
                exit 1;;
 
15
esac
 
16
exit 0
 
17
 
 
18
--- lisp/sawfish/gtk/Makefile.in.orig   Sat Sep  2 13:23:52 2000
 
19
+++ lisp/sawfish/gtk/Makefile.in        Fri Feb 16 18:36:13 2001
 
20
@@ -28,7 +28,7 @@
 
21
 VPATH=@srcdir@:@top_srcdir@
 
22
 
 
23
 REP_GTK_GNOME=@REP_GTK_GNOME@
 
24
-REP_ENVIRON:=$(REP_ENVIRON) REP_LOAD_PATH=$(top_srcdir)/lisp
 
25
+REP_ENVIRON:=$(REP_ENVIRON) REP_LOAD_PATH=$(top_srcdir)/lisp:$(top_builddir)/lisp
 
26
 
 
27
 SRCS :=        color-preview.jl        \
 
28
        stock.jl                \
 
29
--- lisp/sawfish/ui/Makefile.in.orig    Wed Nov 29 00:53:52 2000
 
30
+++ lisp/sawfish/ui/Makefile.in Fri Feb 16 18:36:18 2001
 
31
@@ -28,7 +28,7 @@
 
32
 VPATH=@srcdir@:@top_srcdir@
 
33
 
 
34
 REP_GTK_GNOME=@REP_GTK_GNOME@
 
35
-REP_ENVIRON:=$(REP_ENVIRON) REP_LOAD_PATH=$(top_srcdir)/lisp
 
36
+REP_ENVIRON:=$(REP_ENVIRON) REP_LOAD_PATH=$(top_srcdir)/lisp:$(top_builddir)/lisp
 
37
 
 
38
 ifeq ($(REP_GTK_GNOME),yes)
 
39
  GNOME:=
 
40
--- scripts/Makefile.in.orig    Thu Nov 16 21:59:47 2000
 
41
+++ scripts/Makefile.in Fri Feb 16 18:35:59 2001
 
42
@@ -29,7 +29,7 @@
 
43
 LISP_SRCS := sawfish-menu.jl sawfish-client.jl sawfish-about.jl
 
44
 LISP_OBJS := $(LISP_SRCS:.jl=.jlc)
 
45
 
 
46
-REP_ENVIRON := $(REP_ENVIRON) REP_LOAD_PATH=$(top_srcdir)/lisp
 
47
+REP_ENVIRON := $(REP_ENVIRON) REP_LOAD_PATH=$(top_srcdir)/lisp:$(top_builddir)/lisp
 
48
 
 
49
 SUBSTS := -e "s|__lispdir__|$(lispdir)|" \
 
50
          -e "s|__localedir__|$(localedir)|" \
 
51
--- src/Makefile.in.orig        Fri Sep  1 23:45:15 2000
 
52
+++ src/Makefile.in     Sat Feb 17 10:32:51 2001
 
53
@@ -70,7 +70,7 @@
 
54
        $(foreach x,$(DL_DSTS),\
 
55
          $(rep_LIBTOOL) --mode=install $(INSTALL_PROGRAM) \
 
56
          $(notdir $(x)) $(DESTDIR)$(sawfishexecdir)/$(dir $(x));)
 
57
-       $(rep_INSTALL_ALIASES) -c . $(DESTDIR)$(sawfishexecdir)
 
58
+       $(rep_INSTALL_ALIASES) -c $(srcdir) $(DESTDIR)$(sawfishexecdir)
 
59
        $(rep_LIBTOOL) --mode=install $(INSTALL_PROGRAM) client.la $(DESTDIR)$(repexecdir)/sawfish/
 
60
 
 
61
 uninstall :