~ubuntu-branches/ubuntu/natty/postgresql-8.4/natty-security

« back to all changes in this revision

Viewing changes to debian/patches/07-relax-sslkey-permscheck.patch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2009-07-11 16:59:35 UTC
  • mfrom: (5.1.1 karmic)
  • Revision ID: james.westby@ubuntu.com-20090711165935-jfwin6gfrxf0gfsi
Tags: 8.4.0-2
* debian/libpq-dev.install: Ship catalog/genbki.h. (Closes: #536139)
* debian/rules: Drop --enable-cassert for final release.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -Nur -x '*.orig' -x '*~' postgresql-8.4-8.4~0cvs20090328/src/backend/libpq/be-secure.c postgresql-8.4-8.4~0cvs20090328.new/src/backend/libpq/be-secure.c
2
 
--- postgresql-8.4-8.4~0cvs20090328/src/backend/libpq/be-secure.c       2009-03-28 23:04:14.000000000 +0100
3
 
+++ postgresql-8.4-8.4~0cvs20090328.new/src/backend/libpq/be-secure.c   2009-03-28 23:27:43.543184264 +0100
4
 
@@ -752,12 +752,15 @@
 
1
diff -Nur -x '*.orig' -x '*~' postgresql-8.4-8.4~rc1/src/backend/libpq/be-secure.c postgresql-8.4-8.4~rc1.new/src/backend/libpq/be-secure.c
 
2
--- postgresql-8.4-8.4~rc1/src/backend/libpq/be-secure.c        2009-06-11 16:48:58.000000000 +0200
 
3
+++ postgresql-8.4-8.4~rc1.new/src/backend/libpq/be-secure.c    2009-06-22 07:49:45.873269466 +0200
 
4
@@ -751,12 +751,15 @@
5
5
                 * directory permission check in postmaster.c)
6
6
                 */
7
7
 #if !defined(WIN32) && !defined(__CYGWIN__)
10
10
+                       (buf.st_uid != geteuid()) && buf.st_uid != 0)
11
11
                        ereport(FATAL,
12
12
                                        (errcode(ERRCODE_CONFIG_FILE_ERROR),
13
 
                                         errmsg("private key file \"%s\" has group or world access",
14
 
                                                        SERVER_PRIVATE_KEY_FILE),
15
 
-                                        errdetail("Permissions should be u=rw (0600) or less.")));
 
13
                                  errmsg("private key file \"%s\" has group or world access",
 
14
                                                 SERVER_PRIVATE_KEY_FILE),
 
15
-                                  errdetail("Permissions should be u=rw (0600) or less.")));
16
16
+                                        errdetail("File must be owned by the \
17
17
+database user or root, must have no write permission for \"group\", and must \
18
18
+have no permissions for \"other\".")));