~ubuntu-branches/ubuntu/vivid/qemu/vivid

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/arm64/0072-linux-user-AArch64-define-TARGET_CLONE_BACKWARDS.patch

  • Committer: Package Import Robot
  • Author(s): dann frazier
  • Date: 2014-02-11 15:41:53 UTC
  • Revision ID: package-import@ubuntu.com-20140211154153-2d001tf0ium08u81
Tags: 1.7.0+dfsg-3ubuntu2
* Backport changes to enable qemu-user-static support for aarch64
* debian/control: add ppc64el to Architectures
* debian/rules: only install qemu-system-aarch64 on arm64.
  Fixes a FTBFS  when built twice in a row on non-arm64 due to a stale
  debian/qemu-system-aarch64 directory

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 171880fc200fc1867da424b9741957c70404e492 Mon Sep 17 00:00:00 2001
 
2
From: Claudio Fontana <claudio.fontana@linaro.org>
 
3
Date: Sat, 4 Jan 2014 22:15:47 +0000
 
4
Subject: [PATCH 072/158] linux-user: AArch64: define TARGET_CLONE_BACKWARDS
 
5
 
 
6
The AArch64 linux-user support was written before but merged after
 
7
commit 4ce6243dc621 which cleaned up the handling of the clone()
 
8
syscall argument order, so we failed to notice that AArch64 also needs
 
9
TARGET_CLONE_BACKWARDS to be defined. Add this define so that clone
 
10
and fork syscalls work correctly.
 
11
 
 
12
Signed-off-by: Claudio Fontana <claudio.fontana@linaro.org>
 
13
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
 
14
Reviewed-by: Richard Henderson <rth@twiddle.net>
 
15
---
 
16
 linux-user/aarch64/syscall.h | 1 +
 
17
 1 file changed, 1 insertion(+)
 
18
 
 
19
diff --git a/linux-user/aarch64/syscall.h b/linux-user/aarch64/syscall.h
 
20
index aef419e..18f44a8 100644
 
21
--- a/linux-user/aarch64/syscall.h
 
22
+++ b/linux-user/aarch64/syscall.h
 
23
@@ -7,3 +7,4 @@ struct target_pt_regs {
 
24
 
 
25
 #define UNAME_MACHINE "aarch64"
 
26
 #define UNAME_MINIMUM_RELEASE "3.8.0"
 
27
+#define TARGET_CLONE_BACKWARDS
 
28
-- 
 
29
1.9.rc1
 
30