~ubuntu-branches/ubuntu/vivid/qemu/vivid

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/arm64/0143-tcg-Add-TCGV_UNUSED_PTR-TCGV_IS_UNUSED_PTR-TCGV_EQUA.patch

  • Committer: Package Import Robot
  • Author(s): dann frazier
  • Date: 2014-02-11 15:41:53 UTC
  • Revision ID: package-import@ubuntu.com-20140211154153-2d001tf0ium08u81
Tags: 1.7.0+dfsg-3ubuntu2
* Backport changes to enable qemu-user-static support for aarch64
* debian/control: add ppc64el to Architectures
* debian/rules: only install qemu-system-aarch64 on arm64.
  Fixes a FTBFS  when built twice in a row on non-arm64 due to a stale
  debian/qemu-system-aarch64 directory

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From d590093de06733d77862bf4451620e31e4dd9515 Mon Sep 17 00:00:00 2001
 
2
From: Peter Maydell <peter.maydell@linaro.org>
 
3
Date: Sat, 8 Feb 2014 14:46:55 +0000
 
4
Subject: [PATCH 143/158] tcg: Add TCGV_UNUSED_PTR, TCGV_IS_UNUSED_PTR,
 
5
 TCGV_EQUAL_PTR
 
6
 
 
7
We have macros for marking TCGv values as unused, checking if they
 
8
are unused and comparing them to each other. However these only exist
 
9
for TCGv_i32 and TCGv_i64; add them for TCGv_ptr as well.
 
10
 
 
11
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
 
12
Reviewed-by: Richard Henderson <rth@twiddle.net>
 
13
---
 
14
 tcg/tcg.h | 3 +++
 
15
 1 file changed, 3 insertions(+)
 
16
 
 
17
diff --git a/tcg/tcg.h b/tcg/tcg.h
 
18
index 0d9bd29..775bff6 100644
 
19
--- a/tcg/tcg.h
 
20
+++ b/tcg/tcg.h
 
21
@@ -324,13 +324,16 @@ typedef int TCGv_i64;
 
22
 
 
23
 #define TCGV_EQUAL_I32(a, b) (GET_TCGV_I32(a) == GET_TCGV_I32(b))
 
24
 #define TCGV_EQUAL_I64(a, b) (GET_TCGV_I64(a) == GET_TCGV_I64(b))
 
25
+#define TCGV_EQUAL_PTR(a, b) (GET_TCGV_PTR(a) == GET_TCGV_PTR(b))
 
26
 
 
27
 /* Dummy definition to avoid compiler warnings.  */
 
28
 #define TCGV_UNUSED_I32(x) x = MAKE_TCGV_I32(-1)
 
29
 #define TCGV_UNUSED_I64(x) x = MAKE_TCGV_I64(-1)
 
30
+#define TCGV_UNUSED_PTR(x) x = MAKE_TCGV_PTR(-1)
 
31
 
 
32
 #define TCGV_IS_UNUSED_I32(x) (GET_TCGV_I32(x) == -1)
 
33
 #define TCGV_IS_UNUSED_I64(x) (GET_TCGV_I64(x) == -1)
 
34
+#define TCGV_IS_UNUSED_PTR(x) (GET_TCGV_PTR(x) == -1)
 
35
 
 
36
 /* call flags */
 
37
 /* Helper does not read globals (either directly or through an exception). It
 
38
-- 
 
39
1.9.rc1
 
40