~ubuntu-branches/ubuntu/vivid/qemu/vivid

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/arm64/0111-arm-fix-compile-on-bigendian-host.patch

  • Committer: Package Import Robot
  • Author(s): dann frazier
  • Date: 2014-02-11 15:41:53 UTC
  • Revision ID: package-import@ubuntu.com-20140211154153-2d001tf0ium08u81
Tags: 1.7.0+dfsg-3ubuntu2
* Backport changes to enable qemu-user-static support for aarch64
* debian/control: add ppc64el to Architectures
* debian/rules: only install qemu-system-aarch64 on arm64.
  Fixes a FTBFS  when built twice in a row on non-arm64 due to a stale
  debian/qemu-system-aarch64 directory

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 28ed1ff5909bf476092c12840ace2f678f0dcdc8 Mon Sep 17 00:00:00 2001
 
2
From: Alexey Kardashevskiy <aik@ozlabs.ru>
 
3
Date: Sun, 12 Jan 2014 21:37:37 +0000
 
4
Subject: [PATCH 111/158] arm: fix compile on bigendian host
 
5
 
 
6
Signed-off-by: Alexey Kardashevskiy <aik@ozlabs.ru>
 
7
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
 
8
 
 
9
Conflicts:
 
10
        target-arm/cpu.h
 
11
---
 
12
 target-arm/cpu.h | 2 +-
 
13
 1 file changed, 1 insertion(+), 1 deletion(-)
 
14
 
 
15
diff --git a/target-arm/cpu.h b/target-arm/cpu.h
 
16
index 46c15f4..484728f 100644
 
17
--- a/target-arm/cpu.h
 
18
+++ b/target-arm/cpu.h
 
19
@@ -74,7 +74,7 @@
 
20
  * significant half of a uint64_t struct member.
 
21
  */
 
22
 #ifdef HOST_WORDS_BIGENDIAN
 
23
-#define offsetoflow32(S, M) (offsetof(S, M + sizeof(uint32_t))
 
24
+#define offsetoflow32(S, M) (offsetof(S, M) + sizeof(uint32_t))
 
25
 #else
 
26
 #define offsetoflow32(S, M) offsetof(S, M)
 
27
 #endif
 
28
-- 
 
29
1.9.rc1
 
30