~ubuntu-branches/ubuntu/vivid/qemu/vivid

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/arm64/force-aarch64-uname-to-3.7.0-to-appease-glibc

  • Committer: Package Import Robot
  • Author(s): dann frazier
  • Date: 2014-02-11 15:41:53 UTC
  • Revision ID: package-import@ubuntu.com-20140211154153-2d001tf0ium08u81
Tags: 1.7.0+dfsg-3ubuntu2
* Backport changes to enable qemu-user-static support for aarch64
* debian/control: add ppc64el to Architectures
* debian/rules: only install qemu-system-aarch64 on arm64.
  Fixes a FTBFS  when built twice in a row on non-arm64 due to a stale
  debian/qemu-system-aarch64 directory

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Force aarch64 uname to 3.7.0 to appease glibc
 
2
Author: Adam Conrad <adconrad@ubuntu.com>
 
3
 
 
4
--- qemu-1.6.0+dfsg.orig/linux-user/main.c
 
5
+++ qemu-1.6.0+dfsg/linux-user/main.c
 
6
@@ -69,7 +69,14 @@ unsigned long reserved_va;
 
7
 static void usage(void);
 
8
 
 
9
 static const char *interp_prefix = CONFIG_QEMU_INTERP_PREFIX;
 
10
-const char *qemu_uname_release = CONFIG_UNAME_RELEASE;
 
11
+
 
12
+#ifdef TARGET_AARCH64
 
13
+# define UNAME_RELEASE "3.7.0"
 
14
+#else
 
15
+# define UNAME_RELEASE CONFIG_UNAME_RELEASE
 
16
+#endif
 
17
+
 
18
+const char *qemu_uname_release = UNAME_RELEASE;
 
19
 
 
20
 /* XXX: on x86 MAP_GROWSDOWN only works if ESP <= address + 32, so
 
21
    we allocate a bigger stack. Need a better solution, for example