~ubuntu-branches/ubuntu/maverick/commons-math/maverick

« back to all changes in this revision

Viewing changes to debian/patches/03_define_source_target_class_version.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Damien Raude-Morvan
  • Date: 2009-08-22 01:13:25 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20090822011325-hi4peq1ua5weguwn
Tags: 2.0-1
* New upstream release.
* Set Maintainer field to Debian Java Team
* Add myself as Uploaders
* Switch to Quilt patch system:
  - Refresh all patchs
  - Remove B-D on dpatch, Add B-D on quilt
  - Include patchsys-quilt.mk in debian/rules
* Bump Standards-Version to 3.8.3:
  - Add a README.source to describe patch system
* Maven POMs:
  - Add a Build-Depends-Indep dependency on maven-repo-helper
  - Use mh_installpom and mh_installjar to install the POM and the jar to the
    Maven repository
* Use default-jdk/jre:
  - Depends on java5-runtime-headless
  - Build-Depends on default-jdk
  - Use /usr/lib/jvm/default-java as JAVA_HOME
* Move api documentation to /usr/share/doc/libcommons-math-java/api
* Build-Depends on junit4 instead of junit

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 03_define_source_target_class_version.dpatch by Damien Raude-Morvan <drazzib@drazzib.com>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: build.xml: force -source AND -target at 1.3 class format version.
6
 
 
7
 
@DPATCH@
8
 
diff -urNad trunk~/build.xml trunk/build.xml
9
 
--- trunk~/build.xml    2008-11-03 20:13:19.000000000 +0100
10
 
+++ trunk/build.xml     2008-11-03 20:13:40.000000000 +0100
11
 
@@ -63,7 +63,8 @@
12
 
   <target name="compile" description="o Compile the code">
13
 
     <mkdir dir="${classesdir}">
14
 
     </mkdir>
15
 
-    <javac destdir="${classesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
16
 
+    <javac destdir="${classesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html"
17
 
+       source="1.3" target="1.3">
18
 
       <src>
19
 
         <pathelement location="${basedir}/src/java">
20
 
         </pathelement>
21
 
@@ -138,7 +139,8 @@
22
 
   <target name="compile-tests" if="Junit.present" depends="junit-present,compile">
23
 
     <mkdir dir="${testclassesdir}">
24
 
     </mkdir>
25
 
-    <javac destdir="${testclassesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
26
 
+    <javac destdir="${testclassesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html"
27
 
+       source="1.3" target="1.3">
28
 
       <src>
29
 
         <pathelement location="${basedir}/src/test">
30
 
         </pathelement>