~ubuntu-branches/ubuntu/trusty/brasero/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/012_appindicator.patch

  • Committer: Package Import Robot
  • Author(s): Matthew Fischer
  • Date: 2013-05-26 13:21:27 UTC
  • mfrom: (1.1.56)
  • Revision ID: package-import@ubuntu.com-20130526132127-08owtdhxzr4s6hms
Tags: 3.8.0-0ubuntu1
* New upstream release (LP: #1184409)
  - Documentation fixes
  - Translation updates
  - Add a question mark to a question
  - Support notification filtering
  - Remove nonexisting options from the man page
  - Fix while loop in `brasero_libisofs_write_image_to_fd_thread
* Refreshed patches
* 99_fix-mp3-projects.patch: Removed, already applied upstream

Show diffs side-by-side

added added

removed removed

Lines of Context:
3
3
Bug: https://bugzilla.gnome.org/show_bug.cgi?id=606420
4
4
Bug-Ubuntu: https://launchpad.net/bugs/497853
5
5
 
6
 
Index: brasero-3.4.0/configure.in
 
6
Index: brasero/configure.ac
7
7
===================================================================
8
 
--- brasero-3.4.0.orig/configure.in     2012-03-27 10:40:52.554497115 +1100
9
 
+++ brasero-3.4.0/configure.in  2012-03-27 10:40:53.946497067 +1100
10
 
@@ -366,6 +366,23 @@
 
8
--- brasero.orig/configure.ac   2013-05-26 13:27:09.446673930 -0600
 
9
+++ brasero/configure.ac        2013-05-26 13:27:09.434673930 -0600
 
10
@@ -372,6 +372,23 @@
11
11
 fi
12
12
 AM_CONDITIONAL(BUILD_GROWISOFS, test x"$build_growisofs" = "xyes")
13
13
 
31
31
 TRACKER_REQUIRED=0.10.0
32
32
 
33
33
 AC_ARG_ENABLE(search,
34
 
@@ -624,6 +641,7 @@
 
34
@@ -629,6 +646,7 @@
35
35
        Build growisofs plugins : ${build_growisofs}
36
36
        Build libburnia plugins : ${build_libburnia}
37
37
        Build GObject-Introspection : ${found_introspection}
39
39
 "
40
40
 echo
41
41
 echo
42
 
Index: brasero-3.4.0/libbrasero-burn/Makefile.am
 
42
Index: brasero/libbrasero-burn/Makefile.am
43
43
===================================================================
44
 
--- brasero-3.4.0.orig/libbrasero-burn/Makefile.am      2012-03-27 10:40:50.346497191 +1100
45
 
+++ brasero-3.4.0/libbrasero-burn/Makefile.am   2012-03-27 10:40:53.946497067 +1100
46
 
@@ -197,6 +197,12 @@
 
44
--- brasero.orig/libbrasero-burn/Makefile.am    2013-05-26 13:27:09.446673930 -0600
 
45
+++ brasero/libbrasero-burn/Makefile.am 2013-05-26 13:27:09.434673930 -0600
 
46
@@ -198,6 +198,12 @@
47
47
 libbrasero_burn3_la_SOURCES += brasero-file-monitor.c brasero-file-monitor.h
48
48
 endif
49
49
 
56
56
 EXTRA_DIST =                   \
57
57
        libbrasero-marshal.list
58
58
 #      libbrasero-burn.symbols
59
 
Index: brasero-3.4.0/libbrasero-burn/brasero-app-indicator.c
 
59
Index: brasero/libbrasero-burn/brasero-app-indicator.c
60
60
===================================================================
61
61
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
62
 
+++ brasero-3.4.0/libbrasero-burn/brasero-app-indicator.c       2012-03-27 10:40:53.946497067 +1100
 
62
+++ brasero/libbrasero-burn/brasero-app-indicator.c     2013-05-26 13:27:43.586672932 -0600
63
63
@@ -0,0 +1,367 @@
64
64
+/* -*- Mode: C; indent-tabs-mode: t; c-basic-offset: 8; tab-width: 8 -*- */
65
65
+/*
132
132
+       SHOW_DIALOG_SIGNAL,
133
133
+       LAST_SIGNAL
134
134
+} BraseroAppIndicatorSignalType;
135
 
 
135
+
136
136
+static guint brasero_app_indicator_signals[LAST_SIGNAL] = { 0 };
137
137
+static GObjectClass *parent_class = NULL;
138
138
+
428
428
+       action = gtk_ui_manager_get_action (indicator->priv->manager, "/ContextMenu/Show");
429
429
+       gtk_toggle_action_set_active (GTK_TOGGLE_ACTION (action), show);
430
430
+}
431
 
Index: brasero-3.4.0/libbrasero-burn/brasero-app-indicator.h
 
431
Index: brasero/libbrasero-burn/brasero-app-indicator.h
432
432
===================================================================
433
433
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
434
 
+++ brasero-3.4.0/libbrasero-burn/brasero-app-indicator.h       2012-03-27 10:40:53.946497067 +1100
 
434
+++ brasero/libbrasero-burn/brasero-app-indicator.h     2013-05-26 13:27:25.806673452 -0600
435
435
@@ -0,0 +1,88 @@
436
436
+/* -*- Mode: C; indent-tabs-mode: t; c-basic-offset: 8; tab-width: 8 -*- */
437
437
+/*
450
450
+ * you may extend this exception to your version of the code, but you are not
451
451
+ * obligated to do so. If you do not wish to do so, delete this exception
452
452
+ * statement from your version.
453
 
+ * 
 
453
+ *
454
454
+ * Libbrasero-burn is distributed in the hope that it will be useful,
455
455
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
456
456
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
457
457
+ * GNU Library General Public License for more details.
458
 
+ * 
 
458
+ *
459
459
+ * You should have received a copy of the GNU General Public License
460
460
+ * along with this program; if not, write to:
461
461
+ *     The Free Software Foundation, Inc.,
521
521
+G_END_DECLS
522
522
+
523
523
+#endif /* APP_INDICATOR_H */
524
 
Index: brasero-3.4.0/libbrasero-burn/brasero-burn-dialog.c
 
524
Index: brasero/libbrasero-burn/brasero-burn-dialog.c
525
525
===================================================================
526
 
--- brasero-3.4.0.orig/libbrasero-burn/brasero-burn-dialog.c    2012-03-27 10:40:50.366497191 +1100
527
 
+++ brasero-3.4.0/libbrasero-burn/brasero-burn-dialog.c 2012-03-27 10:40:53.950497067 +1100
 
526
--- brasero.orig/libbrasero-burn/brasero-burn-dialog.c  2013-05-26 13:27:09.446673930 -0600
 
527
+++ brasero/libbrasero-burn/brasero-burn-dialog.c       2013-05-26 13:27:09.438673930 -0600
528
528
@@ -2,6 +2,7 @@
529
529
 /*
530
530
  * Libbrasero-burn
571
571
        /* for our final statistics */
572
572
        GTimer *total_time;
573
573
        gint64 total_size;
574
 
@@ -1269,6 +1287,12 @@
 
574
@@ -1271,6 +1289,12 @@
575
575
                             &written,
576
576
                             &rate);
577
577
 
584
584
        brasero_burn_dialog_progress_changed_real (dialog,
585
585
                                                   written,
586
586
                                                   isosize,
587
 
@@ -1293,6 +1317,12 @@
 
587
@@ -1295,6 +1319,12 @@
588
588
        brasero_burn_progress_set_action (BRASERO_BURN_PROGRESS (priv->progress),
589
589
                                          action,
590
590
                                          string);
597
597
 }
598
598
 
599
599
 static void
600
 
@@ -1454,6 +1484,12 @@
 
600
@@ -1456,6 +1486,12 @@
601
601
                                          -1,
602
602
                                          -1,
603
603
                                          -1);
610
610
 }
611
611
 
612
612
 static void
613
 
@@ -1487,6 +1523,11 @@
 
613
@@ -1489,6 +1525,11 @@
614
614
                                          -1,
615
615
                                          -1,
616
616
                                          -1);
622
622
        /* Restore title */
623
623
        if (priv->initial_title)
624
624
                gtk_window_set_title (GTK_WINDOW (dialog), priv->initial_title);
625
 
@@ -1638,6 +1679,12 @@
 
625
@@ -1640,6 +1681,12 @@
626
626
                                          BRASERO_BURN_ACTION_NONE,
627
627
                                          NULL);
628
628
 
635
635
        g_timer_continue (priv->total_time);
636
636
 
637
637
        return BRASERO_BURN_OK;
638
 
@@ -1655,6 +1702,11 @@
 
638
@@ -1657,6 +1704,11 @@
639
639
 
640
640
        priv = BRASERO_BURN_DIALOG_PRIVATE (dialog);
641
641
 
647
647
        chooser = gtk_file_chooser_dialog_new (_("Save Current Session"),
648
648
                                               GTK_WINDOW (dialog),
649
649
                                               GTK_FILE_CHOOSER_ACTION_SAVE,
650
 
@@ -2516,6 +2568,41 @@
 
650
@@ -2518,6 +2570,41 @@
651
651
        brasero_burn_dialog_cancel (dialog, FALSE);
652
652
 }
653
653
 
689
689
 static void
690
690
 brasero_burn_dialog_init (BraseroBurnDialog * obj)
691
691
 {
692
 
@@ -2528,6 +2615,18 @@
 
692
@@ -2530,6 +2617,18 @@
693
693
 
694
694
        gtk_window_set_default_size (GTK_WINDOW (obj), 500, 0);
695
695
 
708
708
        alignment = gtk_alignment_new (0.5, 0.5, 1.0, 1.0);
709
709
        gtk_widget_show (alignment);
710
710
        gtk_alignment_set_padding (GTK_ALIGNMENT (alignment), 6, 8, 6, 6);
711
 
@@ -2603,6 +2702,13 @@
 
711
@@ -2605,6 +2704,13 @@
712
712
                priv->burn = NULL;
713
713
        }
714
714
 
722
722
        if (priv->session) {
723
723
                g_object_unref (priv->session);
724
724
                priv->session = NULL;
725
 
Index: brasero-3.4.0/po/POTFILES.in
 
725
Index: brasero/po/POTFILES.in
726
726
===================================================================
727
 
--- brasero-3.4.0.orig/po/POTFILES.in   2012-03-27 10:40:50.382497189 +1100
728
 
+++ brasero-3.4.0/po/POTFILES.in        2012-03-27 10:40:53.950497067 +1100
 
727
--- brasero.orig/po/POTFILES.in 2013-05-26 13:27:09.446673930 -0600
 
728
+++ brasero/po/POTFILES.in      2013-05-26 13:27:09.438673930 -0600
729
729
@@ -3,6 +3,7 @@
730
730
 data/brasero.desktop.in.in
731
731
 data/mime/brasero.xml.in