~ubuntu-branches/ubuntu/vivid/qemu/vivid

« back to all changes in this revision

Viewing changes to debian/patches/define-trusty-machine-type.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-25 22:31:43 UTC
  • mfrom: (1.8.5)
  • Revision ID: package-import@ubuntu.com-20140225223143-odhqxfc60wxrjl15
Tags: 2.0.0~rc1+dfsg-0ubuntu1
* Merge 2.0.0-rc1
* debian/rules: consolidate ppc filter entries.
* Move qemu-system-arch64 into qemu-system-arm
* debian/patches/define-trusty-machine-type.patch: define a trusty machine
  type, currently the same as pc-i440fx-2.0, to put is in a better position
  to enable live migrations from trusty onward.  (LP: #1294823)
* debian/control: build-dep on libfdt >= 1.4.0  (LP: #1295072)
* Merge latest upstream git to commit dc9528f
* Debian/rules:
  - remove -enable-uname-release=2.6.32
  - don't make the aarch64 target Ubuntu-specific.
* Remove patches which are now upstream:
  - fix-smb-security-share.patch
  - slirp-smb-redirect-port-445-too.patch 
  - linux-user-Implement-sendmmsg-syscall.patch (better version is upstream)
  - signal-added-a-wrapper-for-sigprocmask-function.patch
  - ubuntu/signal-sigsegv-protection-on-do_sigprocmask.patch
  - ubuntu/Don-t-block-SIGSEGV-at-more-places.patch
  - ubuntu/ppc-force-cpu-threads-count-to-be-power-of-2.patch
* add link for /usr/share/qemu/bios-256k.bin
* Remove all linaro patches.
* Remove all arm64/ patches.  Many but not all are upstream.
* Remove CVE-2013-4377.patch which is upstream.
* debian/control-in: don't make qemu-system-aarch64 ubuntu-specific

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: qemu-2.0~git-20140327.3768d50/hw/i386/pc_piix.c
 
2
===================================================================
 
3
--- qemu-2.0~git-20140327.3768d50.orig/hw/i386/pc_piix.c        2014-03-27 12:55:45.586902968 -0500
 
4
+++ qemu-2.0~git-20140327.3768d50/hw/i386/pc_piix.c     2014-03-27 12:55:45.582902968 -0500
 
5
@@ -390,9 +390,7 @@ static void pc_xen_hvm_init(QEMUMachineI
 
6
 static QEMUMachine pc_i440fx_machine_v2_0 = {
 
7
     PC_I440FX_2_0_MACHINE_OPTIONS,
 
8
     .name = "pc-i440fx-2.0",
 
9
-    .alias = "pc",
 
10
     .init = pc_init_pci,
 
11
-    .is_default = 1,
 
12
 };
 
13
 
 
14
 #define PC_I440FX_1_7_MACHINE_OPTIONS PC_I440FX_MACHINE_OPTIONS
 
15
@@ -839,3 +837,23 @@ static void pc_machine_init(void)
 
16
 }
 
17
 
 
18
 machine_init(pc_machine_init);
 
19
+
 
20
+/* Ubuntu machine types */
 
21
+
 
22
+static QEMUMachine pc_machine_trusty = {
 
23
+       PC_DEFAULT_MACHINE_OPTIONS,
 
24
+       .default_machine_opts = "firmware=bios-256k.bin",
 
25
+       .hot_add_cpu = pc_hot_add_cpu,
 
26
+       .name = "trusty",
 
27
+       .alias = "pc",
 
28
+       .desc = "Ubuntu 14.04 PC (i440FX + PIIX, 1996)", 
 
29
+       .init = pc_init_pci,
 
30
+       .is_default = 1,
 
31
+};
 
32
+
 
33
+static void ubuntu_machine_init(void)
 
34
+{
 
35
+       qemu_register_machine(&pc_machine_trusty);
 
36
+}
 
37
+
 
38
+machine_init(ubuntu_machine_init);