~ubuntu-branches/ubuntu/vivid/qemu/vivid

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/arm64/0088-softfloat-Add-16-bit-integer-to-float-conversions.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-25 22:31:43 UTC
  • mfrom: (1.8.5)
  • Revision ID: package-import@ubuntu.com-20140225223143-odhqxfc60wxrjl15
Tags: 2.0.0~rc1+dfsg-0ubuntu1
* Merge 2.0.0-rc1
* debian/rules: consolidate ppc filter entries.
* Move qemu-system-arch64 into qemu-system-arm
* debian/patches/define-trusty-machine-type.patch: define a trusty machine
  type, currently the same as pc-i440fx-2.0, to put is in a better position
  to enable live migrations from trusty onward.  (LP: #1294823)
* debian/control: build-dep on libfdt >= 1.4.0  (LP: #1295072)
* Merge latest upstream git to commit dc9528f
* Debian/rules:
  - remove -enable-uname-release=2.6.32
  - don't make the aarch64 target Ubuntu-specific.
* Remove patches which are now upstream:
  - fix-smb-security-share.patch
  - slirp-smb-redirect-port-445-too.patch 
  - linux-user-Implement-sendmmsg-syscall.patch (better version is upstream)
  - signal-added-a-wrapper-for-sigprocmask-function.patch
  - ubuntu/signal-sigsegv-protection-on-do_sigprocmask.patch
  - ubuntu/Don-t-block-SIGSEGV-at-more-places.patch
  - ubuntu/ppc-force-cpu-threads-count-to-be-power-of-2.patch
* add link for /usr/share/qemu/bios-256k.bin
* Remove all linaro patches.
* Remove all arm64/ patches.  Many but not all are upstream.
* Remove CVE-2013-4377.patch which is upstream.
* debian/control-in: don't make qemu-system-aarch64 ubuntu-specific

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 312f36883900ec41d012dd75e24a6a693e8834aa Mon Sep 17 00:00:00 2001
2
 
From: Peter Maydell <peter.maydell@linaro.org>
3
 
Date: Tue, 7 Jan 2014 17:17:49 +0000
4
 
Subject: [PATCH 088/158] softfloat: Add 16 bit integer to float conversions
5
 
 
6
 
Add the float to 16 bit integer conversion routines. These can be
7
 
trivially implemented in terms of the int32_to_float* routines, but
8
 
providing them makes our API more symmetrical and can simplify callers.
9
 
 
10
 
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
11
 
Reviewed-by: Richard Henderson <rth@twiddle.net>
12
 
---
13
 
 include/fpu/softfloat.h | 21 +++++++++++++++++++++
14
 
 1 file changed, 21 insertions(+)
15
 
 
16
 
diff --git a/include/fpu/softfloat.h b/include/fpu/softfloat.h
17
 
index a9b8cd9..926d849 100644
18
 
--- a/include/fpu/softfloat.h
19
 
+++ b/include/fpu/softfloat.h
20
 
@@ -239,6 +239,27 @@ floatx80 int64_to_floatx80( int64 STATUS_PARAM );
21
 
 float128 int64_to_float128( int64 STATUS_PARAM );
22
 
 float128 uint64_to_float128( uint64 STATUS_PARAM );
23
 
 
24
 
+/* We provide the int16 versions for symmetry of API with float-to-int */
25
 
+INLINE float32 int16_to_float32(int16_t v STATUS_PARAM)
26
 
+{
27
 
+    return int32_to_float32(v STATUS_VAR);
28
 
+}
29
 
+
30
 
+INLINE float32 uint16_to_float32(uint16_t v STATUS_PARAM)
31
 
+{
32
 
+    return uint32_to_float32(v STATUS_VAR);
33
 
+}
34
 
+
35
 
+INLINE float64 int16_to_float64(int16_t v STATUS_PARAM)
36
 
+{
37
 
+    return int32_to_float64(v STATUS_VAR);
38
 
+}
39
 
+
40
 
+INLINE float64 uint16_to_float64(uint16_t v STATUS_PARAM)
41
 
+{
42
 
+    return uint32_to_float64(v STATUS_VAR);
43
 
+}
44
 
+
45
 
 /*----------------------------------------------------------------------------
46
 
 | Software half-precision conversion routines.
47
 
 *----------------------------------------------------------------------------*/
48
 
1.9.rc1
49