~ubuntu-branches/ubuntu/vivid/qemu/vivid

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/arm64/force-aarch64-uname-to-3.7.0-to-appease-glibc

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-25 22:31:43 UTC
  • mfrom: (1.8.5)
  • Revision ID: package-import@ubuntu.com-20140225223143-odhqxfc60wxrjl15
Tags: 2.0.0~rc1+dfsg-0ubuntu1
* Merge 2.0.0-rc1
* debian/rules: consolidate ppc filter entries.
* Move qemu-system-arch64 into qemu-system-arm
* debian/patches/define-trusty-machine-type.patch: define a trusty machine
  type, currently the same as pc-i440fx-2.0, to put is in a better position
  to enable live migrations from trusty onward.  (LP: #1294823)
* debian/control: build-dep on libfdt >= 1.4.0  (LP: #1295072)
* Merge latest upstream git to commit dc9528f
* Debian/rules:
  - remove -enable-uname-release=2.6.32
  - don't make the aarch64 target Ubuntu-specific.
* Remove patches which are now upstream:
  - fix-smb-security-share.patch
  - slirp-smb-redirect-port-445-too.patch 
  - linux-user-Implement-sendmmsg-syscall.patch (better version is upstream)
  - signal-added-a-wrapper-for-sigprocmask-function.patch
  - ubuntu/signal-sigsegv-protection-on-do_sigprocmask.patch
  - ubuntu/Don-t-block-SIGSEGV-at-more-places.patch
  - ubuntu/ppc-force-cpu-threads-count-to-be-power-of-2.patch
* add link for /usr/share/qemu/bios-256k.bin
* Remove all linaro patches.
* Remove all arm64/ patches.  Many but not all are upstream.
* Remove CVE-2013-4377.patch which is upstream.
* debian/control-in: don't make qemu-system-aarch64 ubuntu-specific

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Force aarch64 uname to 3.7.0 to appease glibc
2
 
Author: Adam Conrad <adconrad@ubuntu.com>
3
 
 
4
 
--- qemu-1.6.0+dfsg.orig/linux-user/main.c
5
 
+++ qemu-1.6.0+dfsg/linux-user/main.c
6
 
@@ -69,7 +69,14 @@ unsigned long reserved_va;
7
 
 static void usage(void);
8
 
 
9
 
 static const char *interp_prefix = CONFIG_QEMU_INTERP_PREFIX;
10
 
-const char *qemu_uname_release = CONFIG_UNAME_RELEASE;
11
 
+
12
 
+#ifdef TARGET_AARCH64
13
 
+# define UNAME_RELEASE "3.7.0"
14
 
+#else
15
 
+# define UNAME_RELEASE CONFIG_UNAME_RELEASE
16
 
+#endif
17
 
+
18
 
+const char *qemu_uname_release = UNAME_RELEASE;
19
 
 
20
 
 /* XXX: on x86 MAP_GROWSDOWN only works if ESP <= address + 32, so
21
 
    we allocate a bigger stack. Need a better solution, for example