~ubuntu-branches/ubuntu/vivid/qemu/vivid

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/linaro/0031-fix-omap_spi-rxs-flag-status-update.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-25 22:31:43 UTC
  • mfrom: (1.8.5)
  • Revision ID: package-import@ubuntu.com-20140225223143-odhqxfc60wxrjl15
Tags: 2.0.0~rc1+dfsg-0ubuntu1
* Merge 2.0.0-rc1
* debian/rules: consolidate ppc filter entries.
* Move qemu-system-arch64 into qemu-system-arm
* debian/patches/define-trusty-machine-type.patch: define a trusty machine
  type, currently the same as pc-i440fx-2.0, to put is in a better position
  to enable live migrations from trusty onward.  (LP: #1294823)
* debian/control: build-dep on libfdt >= 1.4.0  (LP: #1295072)
* Merge latest upstream git to commit dc9528f
* Debian/rules:
  - remove -enable-uname-release=2.6.32
  - don't make the aarch64 target Ubuntu-specific.
* Remove patches which are now upstream:
  - fix-smb-security-share.patch
  - slirp-smb-redirect-port-445-too.patch 
  - linux-user-Implement-sendmmsg-syscall.patch (better version is upstream)
  - signal-added-a-wrapper-for-sigprocmask-function.patch
  - ubuntu/signal-sigsegv-protection-on-do_sigprocmask.patch
  - ubuntu/Don-t-block-SIGSEGV-at-more-places.patch
  - ubuntu/ppc-force-cpu-threads-count-to-be-power-of-2.patch
* add link for /usr/share/qemu/bios-256k.bin
* Remove all linaro patches.
* Remove all arm64/ patches.  Many but not all are upstream.
* Remove CVE-2013-4377.patch which is upstream.
* debian/control-in: don't make qemu-system-aarch64 ubuntu-specific

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From dd727f3a405f7c7064d266562362cbef4522e608 Mon Sep 17 00:00:00 2001
2
 
From: =?UTF-8?q?Juha=20Riihim=C3=A4ki?= <juha.riihimaki@nokia.com>
3
 
Date: Mon, 18 Feb 2013 16:58:28 +0000
4
 
Subject: [PATCH 31/70] fix omap_spi rxs flag status update
5
 
MIME-Version: 1.0
6
 
Content-Type: text/plain; charset=UTF-8
7
 
Content-Transfer-Encoding: 8bit
8
 
 
9
 
Signed-off-by: Juha Riihimäki <juha.riihimaki@nokia.com>
10
 
---
11
 
 hw/ssi/omap_spi.c | 5 ++++-
12
 
 1 file changed, 4 insertions(+), 1 deletion(-)
13
 
 
14
 
diff --git a/hw/ssi/omap_spi.c b/hw/ssi/omap_spi.c
15
 
index 30392ac..37cc69d 100644
16
 
--- a/hw/ssi/omap_spi.c
17
 
+++ b/hw/ssi/omap_spi.c
18
 
@@ -232,8 +232,11 @@ static void omap_mcspi_transfer_run(OMAPSPIBusState *s, int chnum)
19
 
     ch->tx = 0;
20
 
     ch->status |= 1 << 2;               /* EOT */
21
 
     ch->status |= 1 << 1;               /* TXS */
22
 
-    if (trm != 2)
23
 
+    if (trm != 2) {
24
 
         ch->status |= 1;                /* RXS */
25
 
+    } else {
26
 
+        ch->status &= ~1;               /* RXS */
27
 
+    }
28
 
 
29
 
 intr_update:
30
 
     if ((ch->status & 1) &&    trm != 2 &&                     /* RXS */
31
 
1.8.5.2
32