~ubuntu-branches/ubuntu/vivid/qemu/vivid

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/linaro/0024-hw-omap_i2c-Treat-32-bit-accesses-like-16-bit-access.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-25 22:31:43 UTC
  • mfrom: (1.8.5)
  • Revision ID: package-import@ubuntu.com-20140225223143-odhqxfc60wxrjl15
Tags: 2.0.0~rc1+dfsg-0ubuntu1
* Merge 2.0.0-rc1
* debian/rules: consolidate ppc filter entries.
* Move qemu-system-arch64 into qemu-system-arm
* debian/patches/define-trusty-machine-type.patch: define a trusty machine
  type, currently the same as pc-i440fx-2.0, to put is in a better position
  to enable live migrations from trusty onward.  (LP: #1294823)
* debian/control: build-dep on libfdt >= 1.4.0  (LP: #1295072)
* Merge latest upstream git to commit dc9528f
* Debian/rules:
  - remove -enable-uname-release=2.6.32
  - don't make the aarch64 target Ubuntu-specific.
* Remove patches which are now upstream:
  - fix-smb-security-share.patch
  - slirp-smb-redirect-port-445-too.patch 
  - linux-user-Implement-sendmmsg-syscall.patch (better version is upstream)
  - signal-added-a-wrapper-for-sigprocmask-function.patch
  - ubuntu/signal-sigsegv-protection-on-do_sigprocmask.patch
  - ubuntu/Don-t-block-SIGSEGV-at-more-places.patch
  - ubuntu/ppc-force-cpu-threads-count-to-be-power-of-2.patch
* add link for /usr/share/qemu/bios-256k.bin
* Remove all linaro patches.
* Remove all arm64/ patches.  Many but not all are upstream.
* Remove CVE-2013-4377.patch which is upstream.
* debian/control-in: don't make qemu-system-aarch64 ubuntu-specific

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 89eda41590411f9402a62c05647c4c271af40436 Mon Sep 17 00:00:00 2001
2
 
From: Peter Maydell <peter.maydell@linaro.org>
3
 
Date: Mon, 18 Feb 2013 16:58:27 +0000
4
 
Subject: [PATCH 24/70] hw/omap_i2c: Treat 32 bit accesses like 16 bit accesses
5
 
 
6
 
Treat 32 bit OMAP i2c register accesses like 16 bit accesses, working
7
 
around the kernel bug LP:727781 where it makes 32 bit accesses in violation
8
 
of the TRM. (Hardware behaviour is apparently that OMAP2 will abort on
9
 
these 32 bit accesses, but OMAP3 and 4 will allow them.)
10
 
 
11
 
We might need to revert or rethink this patch as part of handling silencing
12
 
of bad-kernel-behaviour warnings more consistently so that they can be
13
 
upstreamed.
14
 
 
15
 
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
16
 
---
17
 
 hw/i2c/omap_i2c.c | 4 ++--
18
 
 1 file changed, 2 insertions(+), 2 deletions(-)
19
 
 
20
 
diff --git a/hw/i2c/omap_i2c.c b/hw/i2c/omap_i2c.c
21
 
index 93e85d4..353ca46 100644
22
 
--- a/hw/i2c/omap_i2c.c
23
 
+++ b/hw/i2c/omap_i2c.c
24
 
@@ -649,12 +649,12 @@ static const MemoryRegionOps omap_i2c_ops = {
25
 
         .read = {
26
 
             omap_i2c_readb,
27
 
             omap_i2c_read,
28
 
-            omap_badwidth_read16,
29
 
+            omap_i2c_read,
30
 
         },
31
 
         .write = {
32
 
             omap_i2c_writeb, /* Only the last fifo write can be 8 bit.  */
33
 
             omap_i2c_write,
34
 
-            omap_badwidth_write16,
35
 
+            omap_i2c_write,
36
 
         },
37
 
     },
38
 
     .endianness = DEVICE_NATIVE_ENDIAN,
39
 
1.8.5.2
40