~ubuntu-branches/ubuntu/vivid/qemu/vivid

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu/linaro/0016-omap_i2c-clean-up-revision-numbers.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2014-02-25 22:31:43 UTC
  • mfrom: (1.8.5)
  • Revision ID: package-import@ubuntu.com-20140225223143-odhqxfc60wxrjl15
Tags: 2.0.0~rc1+dfsg-0ubuntu1
* Merge 2.0.0-rc1
* debian/rules: consolidate ppc filter entries.
* Move qemu-system-arch64 into qemu-system-arm
* debian/patches/define-trusty-machine-type.patch: define a trusty machine
  type, currently the same as pc-i440fx-2.0, to put is in a better position
  to enable live migrations from trusty onward.  (LP: #1294823)
* debian/control: build-dep on libfdt >= 1.4.0  (LP: #1295072)
* Merge latest upstream git to commit dc9528f
* Debian/rules:
  - remove -enable-uname-release=2.6.32
  - don't make the aarch64 target Ubuntu-specific.
* Remove patches which are now upstream:
  - fix-smb-security-share.patch
  - slirp-smb-redirect-port-445-too.patch 
  - linux-user-Implement-sendmmsg-syscall.patch (better version is upstream)
  - signal-added-a-wrapper-for-sigprocmask-function.patch
  - ubuntu/signal-sigsegv-protection-on-do_sigprocmask.patch
  - ubuntu/Don-t-block-SIGSEGV-at-more-places.patch
  - ubuntu/ppc-force-cpu-threads-count-to-be-power-of-2.patch
* add link for /usr/share/qemu/bios-256k.bin
* Remove all linaro patches.
* Remove all arm64/ patches.  Many but not all are upstream.
* Remove CVE-2013-4377.patch which is upstream.
* debian/control-in: don't make qemu-system-aarch64 ubuntu-specific

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From b800580dbe280c17fefe098c44cdca14d56ec28c Mon Sep 17 00:00:00 2001
2
 
From: Peter Maydell <peter.maydell@linaro.org>
3
 
Date: Mon, 18 Feb 2013 16:58:26 +0000
4
 
Subject: [PATCH 16/70] omap_i2c: clean up revision numbers
5
 
 
6
 
---
7
 
 hw/i2c/omap_i2c.c | 9 ++++++---
8
 
 1 file changed, 6 insertions(+), 3 deletions(-)
9
 
 
10
 
diff --git a/hw/i2c/omap_i2c.c b/hw/i2c/omap_i2c.c
11
 
index f528b2b..7d47dc7 100644
12
 
--- a/hw/i2c/omap_i2c.c
13
 
+++ b/hw/i2c/omap_i2c.c
14
 
@@ -51,8 +51,11 @@ typedef struct OMAPI2CState {
15
 
     uint16_t test;
16
 
 } OMAPI2CState;
17
 
 
18
 
-#define OMAP2_INTR_REV 0x34
19
 
-#define OMAP2_GC_REV   0x34
20
 
+/* I2C controller revision register values */
21
 
+#define OMAP1_INTR_REV    0x11
22
 
+#define OMAP2_INTR_REV    0x34
23
 
+#define OMAP3_INTR_REV    0x3c
24
 
+#define OMAP3630_INTR_REV 0x40
25
 
 
26
 
 static void omap_i2c_interrupts_update(OMAPI2CState *s)
27
 
 {
28
 
@@ -266,7 +269,7 @@ static void omap_i2c_write(void *opaque, hwaddr addr,
29
 
         return;
30
 
 
31
 
     case 0x04: /* I2C_IE */
32
 
-        s->mask = value & (s->revision < OMAP2_GC_REV ? 0x1f : 0x3f);
33
 
+        s->mask = value & (s->revision < OMAP2_INTR_REV ? 0x1f : 0x3f);
34
 
         break;
35
 
 
36
 
     case 0x08: /* I2C_STAT */
37
 
1.8.5.2
38