~jderose/ubuntu/raring/qemu/vde-again

« back to all changes in this revision

Viewing changes to debian/patches/11_signal_sigaction.patch

  • Committer: Bazaar Package Importer
  • Author(s): Aurelien Jarno, Aurelien Jarno
  • Date: 2009-03-22 10:13:17 UTC
  • mfrom: (1.2.1 upstream) (6.1.1 sid)
  • Revision ID: james.westby@ubuntu.com-20090322101317-iigjtnu5qil35dtb
Tags: 0.10.1-1
[ Aurelien Jarno ]
* New upstream stable release:
  - patches/80_stable-branch.patch: remove.
* debian/control: 
  - Remove depends on proll.
  - Move depends on device-tree-compiler to build-depends.
  - Bump Standards-Version to 3.8.1 (no changes).
* patches/82_qemu-img_decimal.patch: new patch from upstream to make
  qemu-img accept sizes with decimal values (closes: bug#501400).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: linux-user/signal.c
2
 
===================================================================
3
 
--- linux-user/signal.c.orig    2008-04-14 11:26:14.000000000 +0200
4
 
+++ linux-user/signal.c 2008-04-14 11:27:38.000000000 +0200
5
 
@@ -512,6 +512,11 @@
6
 
 
7
 
     if (sig < 1 || sig > TARGET_NSIG || sig == SIGKILL || sig == SIGSTOP)
8
 
         return -EINVAL;
9
 
+
10
 
+    /* no point doing the stuff as those are not allowed for sigaction */
11
 
+    if ((sig == TARGET_SIGKILL) || (sig == TARGET_SIGSTOP))
12
 
+        return -EINVAL;
13
 
+
14
 
     k = &sigact_table[sig - 1];
15
 
 #if defined(DEBUG_SIGNAL)
16
 
     fprintf(stderr, "sigaction sig=%d act=0x%08x, oact=0x%08x\n",