~jderose/ubuntu/raring/qemu/vde-again

« back to all changes in this revision

Viewing changes to debian/patches/96_security.patch

  • Committer: Bazaar Package Importer
  • Author(s): Aurelien Jarno, Aurelien Jarno
  • Date: 2009-03-22 10:13:17 UTC
  • mfrom: (1.2.1 upstream) (6.1.1 sid)
  • Revision ID: james.westby@ubuntu.com-20090322101317-iigjtnu5qil35dtb
Tags: 0.10.1-1
[ Aurelien Jarno ]
* New upstream stable release:
  - patches/80_stable-branch.patch: remove.
* debian/control: 
  - Remove depends on proll.
  - Move depends on device-tree-compiler to build-depends.
  - Bump Standards-Version to 3.8.1 (no changes).
* patches/82_qemu-img_decimal.patch: new patch from upstream to make
  qemu-img accept sizes with decimal values (closes: bug#501400).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
commit 7e5b685255b2dbc9d96f954c86fcc86a56fee0c6
2
 
Author: aliguori <aliguori@c046a42c-6fe2-441c-8c8c-71466251a162>
3
 
Date:   Wed Dec 10 15:12:57 2008 +0000
4
 
 
5
 
    Fix off-by-one bug limiting VNC passwords to 7 chars (Chris Webb)
6
 
    
7
 
    monitor_readline expects buf_size to include the terminating \0, but
8
 
    do_change_vnc in monitor.c calls it as though it doesn't. The other site
9
 
    where monitor_readline reads a password (in vl.c) passes the buffer
10
 
    length
11
 
    correctly.
12
 
    
13
 
    Signed-off-by: Chris Webb <chris@arachsys.com>
14
 
    Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
15
 
    
16
 
    
17
 
    
18
 
    git-svn-id: svn+ssh://svn.savannah.nongnu.org/qemu/trunk@5966 c046a42c-6fe2-441c-8c8c-71466251a162
19
 
 
20
 
diff --git a/monitor.c b/monitor.c
21
 
index f142a87..bec9211 100644
22
 
--- a/monitor.c
23
 
+++ b/monitor.c
24
 
@@ -434,8 +434,7 @@ static void do_change_vnc(const char *target)
25
 
     if (strcmp(target, "passwd") == 0 ||
26
 
        strcmp(target, "password") == 0) {
27
 
        char password[9];
28
 
-       monitor_readline("Password: ", 1, password, sizeof(password)-1);
29
 
-       password[sizeof(password)-1] = '\0';
30
 
+       monitor_readline("Password: ", 1, password, sizeof(password));
31
 
        if (vnc_display_password(NULL, password) < 0)
32
 
            term_printf("could not set VNC server password\n");
33
 
     } else {