~jderose/ubuntu/raring/qemu/vde-again

« back to all changes in this revision

Viewing changes to debian/patches/50_linuxbios_isa_bios_ram.patch

  • Committer: Bazaar Package Importer
  • Author(s): Aurelien Jarno, Aurelien Jarno
  • Date: 2009-03-22 10:13:17 UTC
  • mfrom: (1.2.1 upstream) (6.1.1 sid)
  • Revision ID: james.westby@ubuntu.com-20090322101317-iigjtnu5qil35dtb
Tags: 0.10.1-1
[ Aurelien Jarno ]
* New upstream stable release:
  - patches/80_stable-branch.patch: remove.
* debian/control: 
  - Remove depends on proll.
  - Move depends on device-tree-compiler to build-depends.
  - Bump Standards-Version to 3.8.1 (no changes).
* patches/82_qemu-img_decimal.patch: new patch from upstream to make
  qemu-img accept sizes with decimal values (closes: bug#501400).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: hw/pc.c
 
1
Index: qemu-0.10.0/hw/pc.c
2
2
===================================================================
3
 
--- hw/pc.c.orig        2008-04-14 11:26:14.000000000 +0200
4
 
+++ hw/pc.c     2008-04-14 11:27:35.000000000 +0200
5
 
@@ -794,15 +794,13 @@
6
 
     cpu_register_physical_memory(0xc0000, 0x10000,
7
 
                                  vga_bios_offset | IO_MEM_ROM);
 
3
--- qemu-0.10.0.orig/hw/pc.c    2009-03-07 13:46:58.000000000 +0100
 
4
+++ qemu-0.10.0/hw/pc.c 2009-03-07 13:47:27.000000000 +0100
 
5
@@ -823,6 +823,7 @@
 
6
      * and some bios areas, which will be registered later
 
7
      */
 
8
     ram_addr = qemu_ram_alloc(0x100000 - 0xa0000);
 
9
+    cpu_register_physical_memory(0xa0000, 0x100000 - 0xa0000, ram_addr);
 
10
     ram_addr = qemu_ram_alloc(below_4g_mem_size - 0x100000);
 
11
     cpu_register_physical_memory(0x100000,
 
12
                  below_4g_mem_size - 0x100000,
 
13
@@ -881,13 +882,13 @@
 
14
                                      vga_bios_offset | IO_MEM_ROM);
 
15
     }
8
16
 
9
17
-    /* map the last 128KB of the BIOS in ISA space */
10
18
+    /* copy the last 128KB of the BIOS to ISA space */
11
19
     isa_bios_size = bios_size;
12
20
     if (isa_bios_size > (128 * 1024))
13
21
         isa_bios_size = 128 * 1024;
14
 
-    cpu_register_physical_memory(0xd0000, (192 * 1024) - isa_bios_size,
15
 
-                                 IO_MEM_UNASSIGNED);
16
22
-    cpu_register_physical_memory(0x100000 - isa_bios_size,
17
23
-                                 isa_bios_size,
18
24
-                                 (bios_offset + bios_size - isa_bios_size) | IO_MEM_ROM);