~jderose/ubuntu/raring/qemu/vde-again

« back to all changes in this revision

Viewing changes to debian/patches/22_net_tuntap_stall.patch

  • Committer: Bazaar Package Importer
  • Author(s): Aurelien Jarno, Aurelien Jarno
  • Date: 2009-03-22 10:13:17 UTC
  • mfrom: (1.2.1 upstream) (6.1.1 sid)
  • Revision ID: james.westby@ubuntu.com-20090322101317-iigjtnu5qil35dtb
Tags: 0.10.1-1
[ Aurelien Jarno ]
* New upstream stable release:
  - patches/80_stable-branch.patch: remove.
* debian/control: 
  - Remove depends on proll.
  - Move depends on device-tree-compiler to build-depends.
  - Bump Standards-Version to 3.8.1 (no changes).
* patches/82_qemu-img_decimal.patch: new patch from upstream to make
  qemu-img accept sizes with decimal values (closes: bug#501400).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: vl.c
2
 
===================================================================
3
 
--- vl.c.orig   2008-04-14 11:26:13.000000000 +0200
4
 
+++ vl.c        2008-04-14 11:27:19.000000000 +0200
5
 
@@ -4085,7 +4085,7 @@
6
 
         return -1;
7
 
     }
8
 
     memset(&ifr, 0, sizeof(ifr));
9
 
-    ifr.ifr_flags = IFF_TAP | IFF_NO_PI;
10
 
+    ifr.ifr_flags = IFF_TAP | IFF_NO_PI | IFF_ONE_QUEUE;
11
 
     if (ifname[0] != '\0')
12
 
         pstrcpy(ifr.ifr_name, IFNAMSIZ, ifname);
13
 
     else