~jderose/ubuntu/raring/qemu/vde-again

« back to all changes in this revision

Viewing changes to debian/patches/51_linuxbios_piix_ram_size.patch

  • Committer: Bazaar Package Importer
  • Author(s): Aurelien Jarno, Aurelien Jarno
  • Date: 2009-03-22 10:13:17 UTC
  • mfrom: (1.2.1 upstream) (6.1.1 sid)
  • Revision ID: james.westby@ubuntu.com-20090322101317-iigjtnu5qil35dtb
Tags: 0.10.1-1
[ Aurelien Jarno ]
* New upstream stable release:
  - patches/80_stable-branch.patch: remove.
* debian/control: 
  - Remove depends on proll.
  - Move depends on device-tree-compiler to build-depends.
  - Bump Standards-Version to 3.8.1 (no changes).
* patches/82_qemu-img_decimal.patch: new patch from upstream to make
  qemu-img accept sizes with decimal values (closes: bug#501400).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: hw/pc.c
 
1
Index: qemu-0.10.0/hw/pc.c
2
2
===================================================================
3
 
--- hw/pc.c.orig        2008-04-14 11:26:14.000000000 +0200
4
 
+++ hw/pc.c     2008-04-14 11:27:17.000000000 +0200
5
 
@@ -844,7 +844,7 @@
 
3
--- qemu-0.10.0.orig/hw/pc.c    2009-03-07 13:47:27.000000000 +0100
 
4
+++ qemu-0.10.0/hw/pc.c 2009-03-07 13:47:27.000000000 +0100
 
5
@@ -938,7 +938,7 @@
6
6
     ferr_irq = i8259[13];
7
7
 
8
8
     if (pci_enabled) {
11
11
         piix3_devfn = piix3_init(pci_bus, -1);
12
12
     } else {
13
13
         pci_bus = NULL;
14
 
Index: hw/pc.h
 
14
Index: qemu-0.10.0/hw/pc.h
15
15
===================================================================
16
 
--- hw/pc.h.orig        2008-01-06 20:38:42.000000000 +0100
17
 
+++ hw/pc.h     2008-04-14 11:26:14.000000000 +0200
18
 
@@ -97,7 +97,7 @@
 
16
--- qemu-0.10.0.orig/hw/pc.h    2009-03-07 13:46:58.000000000 +0100
 
17
+++ qemu-0.10.0/hw/pc.h 2009-03-07 13:47:27.000000000 +0100
 
18
@@ -112,7 +112,7 @@
19
19
 int pcspk_audio_init(AudioState *, qemu_irq *pic);
20
20
 
21
21
 /* piix_pci.c */
24
24
 void i440fx_set_smm(PCIDevice *d, int val);
25
25
 int piix3_init(PCIBus *bus, int devfn);
26
26
 void i440fx_init_memory_mappings(PCIDevice *d);
27
 
Index: hw/piix_pci.c
 
27
Index: qemu-0.10.0/hw/piix_pci.c
28
28
===================================================================
29
 
--- hw/piix_pci.c.orig  2008-01-06 20:38:42.000000000 +0100
30
 
+++ hw/piix_pci.c       2008-04-14 11:26:14.000000000 +0200
 
29
--- qemu-0.10.0.orig/hw/piix_pci.c      2009-03-07 13:46:58.000000000 +0100
 
30
+++ qemu-0.10.0/hw/piix_pci.c   2009-03-07 13:47:27.000000000 +0100
31
31
@@ -169,7 +169,7 @@
32
32
     return 0;
33
33
 }
37
37
 {
38
38
     PCIBus *b;
39
39
     PCIDevice *d;
40
 
@@ -200,6 +200,10 @@
41
 
     d->config[0x0a] = 0x00; // class_sub = host2pci
42
 
     d->config[0x0b] = 0x06; // class_base = PCI_bridge
 
40
@@ -197,6 +197,10 @@
 
41
     d->config[0x08] = 0x02; // revision
 
42
     pci_config_set_class(d->config, PCI_CLASS_BRIDGE_HOST);
43
43
     d->config[0x0e] = 0x00; // header_type
44
44
+    ram_size = ram_size / 8 / 1024 / 1024;
45
45
+    if (ram_size > 255)