~ubuntu-branches/debian/jessie/arb/jessie

« back to all changes in this revision

Viewing changes to debian/patches/20_config.makefiles

  • Committer: Package Import Robot
  • Author(s): Elmar Pruesse, Andreas Tille, Elmar Pruesse
  • Date: 2014-09-02 15:15:06 UTC
  • mfrom: (1.1.6)
  • Revision ID: package-import@ubuntu.com-20140902151506-jihq58b3iz342wif
Tags: 6.0.2-1
[ Andreas Tille ]
* New upstream version
  Closes: #741890
* debian/upstream -> debian/upstream/metadata
* debian/control:
   - Build-Depends: added libglib2.0-dev
   - Depends: added mafft, mrbayes
* debian/rules
   - Add explicite --remove-section=.comment option to manual strip call
* cme fix dpkg-control
* arb-common.dirs: Do not create unneeded lintian dir
* Add turkish debconf translation (thanks for the patch to Mert Dirik
  <mertdirik@gmail.com>)
  Closes: #757497

[ Elmar Pruesse ]
* patches removed:
   - 10_config.makefiles.patch,
     80_no_GL.patch
       removed in favor of creating file from config.makefile.template via 
       sed in debian/control
   - 20_Makefile_main.patch
       merged upstream
   - 21_Makefiles.patch
       no longer needed
   - 30_tmpfile_CVE-2008-5378.patch: 
       merged upstream
   - 50_fix_gcc-4.8.patch:
       merged upstream
   - 40_add_libGLU.patch:
       libGLU not needed for arb_ntree)
   - 60_use_debian_packaged_raxml.patch:
       merged upstream
   - 70_hardening.patch
       merged upstream
   - 72_add_math_lib_to_linker.patch
       does not appear to be needed
* patches added:
   - 10_upstream_r12793__show_db_load_progress:
       backported patch showing progress while ARB is loading a database
       (needed as indicator/splash screen while ARB is launching)
   - 20_upstream_r12794__socket_permissions:
       backported security fix
   - 30_upstream_r12814__desktop_keywords:
       backported add keywords to desktop (fixes lintian warning)
   - 40_upstream_r12815__lintian_spelling:
       backported fix for lintian reported spelling errors
   - 50_private_nameservers
       change configuration to put nameservers into users home dirs
       (avoids need for shared writeable directory)
   - 60_use_debian_phyml
       use phyml from debian package for both interfaces in ARB
* debian/rules:
   - create config.makefile from override_dh_configure target
   - use "make tarfile" in override_dh_install
   - remove extra cleaning not needed for ARB 6
   - use "dh_install --list-missing" to avoid missing files
   - added override_dh_fixperms target
* debian/control:
   - added libarb-dev package
   - Depends: added phyml, xdg-utils
   - Suggests: removed phyml
   - fix lintian duplicate-short-description (new descriptions)
* debian/*.install:
   - "unrolled" confusing globbing to select files
   - pick files from debian/tmp
   - moved all config files to /etc/arb
* debian/arb-common.templates: updated
* scripts:
   - removed arb-add-pt-server
   - launch-wrapper: 
     - only add demo.arb to newly created $ARBUSERDATA
     - pass commandline arguments through bin/arb wrapper
   - preinst: removing old PT server index files on upgrade from 5.5*
   - postinst: set setgid on shared PT dir
* rewrote arb.1 manfile
* added file icon for ARB databases
* using upstream arb_tcp.dat

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Author: Andreas Tille <tille@debian.org>
2
 
Description: Set basic makefile configuration variables
3
 
 
4
 
--- /dev/null
5
 
+++ b/config.makefile
6
 
@@ -0,0 +1,27 @@
7
 
+# --------------------------------------------------------------------------------
8
 
+# If this file is named config.makefile.template then copy it to config.makefile
9
 
+# DO NOT EDIT config.makefile.template
10
 
+# --------------------------------------------------------------------------------
11
 
+
12
 
+# Enter your name (upper case, no spaces) here, to enable '#ifdef DEVEL_YOURNAME #endif' sections
13
 
+DEVELOPER=ANY
14
 
+
15
 
+DEBUG=0# build with debug information
16
 
+DEBUG_GRAPHICS = 0# force instant graphic update
17
 
+# SEER = 1
18
 
+OPENGL=1
19
 
+# ARB_64=0# compile on 64 bit machine (has no effect yet)
20
 
+ARB_64 := $(shell if [ `dpkg-architecture -qDEB_BUILD_ARCH_BITS` -eq 64 ] ; then echo 1 ; else echo 0 ; fi)
21
 
+
22
 
+# --------------------------------------------------------------------------------
23
 
+# target machine section
24
 
+# [Note: Uncomment one section, depending on your machine type and compiler options]
25
 
+
26
 
+# ********* LINUX / gcc g++ / static ********
27
 
+MACH  = LINUX# Linux g++  and gcc
28
 
+LINUX = 1
29
 
+ECGS  = 1# use GCC? (always 1 for LINUX)
30
 
+
31
 
+# ******** Debian GNU/Linux and (K)Ubuntu system ********
32
 
+DEBIAN = 1
33
 
+