~ubuntu-branches/ubuntu/trusty/wget/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/wget-doc-remove-usr-local-in-sample.wgetrc

  • Committer: Bazaar Package Importer
  • Author(s): Steve Langasek
  • Date: 2011-05-17 19:46:25 UTC
  • mfrom: (2.1.10 sid)
  • Revision ID: james.westby@ubuntu.com-20110517194625-awyf9lkvyohk71ni
Tags: 1.12-3.1ubuntu1
* Merge from Debian unstable, remaining changes:
  - Add wget-udeb to ship wget.gnu as alternative to busybox wget
    implementation.
  - Keep build dependencies in main:
    + debian/control: remove info2man build-dep
    + debian/patches/series: disable wget-infopod_generated_manpage
  - Depend on libssl-dev 0.9.8k-7ubuntu4 (LP: #503339)
  - Mark wget Multi-Arch: foreign, so packages that aren't of the same arch
    can depend on it.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#!/bin/sh -e
2
 
## wget-doc-wgetrc-path-in-sample.wgetrc by Noèl Köthe <noel debian.org>
3
 
##
4
 
## DP: corrects the wgetrc path from /usr/local/etc/ to /etc/wgetrc in the
5
 
## DP: sample wgetrc
6
 
 
7
 
if [ $# -lt 1 ]; then
8
 
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
9
 
    exit 1
10
 
fi
11
 
 
12
 
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
13
 
patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
14
 
 
15
 
case "$1" in
16
 
       -patch) patch $patch_opts -p1 < $0;;
17
 
       -unpatch) patch $patch_opts -p1 -R < $0;;
18
 
        *)
19
 
                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
20
 
                exit 1;;
21
 
esac
22
 
 
23
 
exit 0
24
 
 
25
 
@DPATCH@
26
 
--- wget-1.9.1.orig/doc/sample.wgetrc
27
 
+++ wget-1.9.1/doc/sample.wgetrc
 
1
corrects the wgetrc path from /usr/local/etc/ to /etc/wgetrc in the sample wgetrc
 
2
 
 
3
--- a/doc/sample.wgetrc
 
4
+++ b/doc/sample.wgetrc
28
5
@@ -7,7 +7,7 @@
29
6
 ## not contain a comprehensive list of commands -- look at the manual
30
7
 ## to find out what you can put into this file.