~ubuntu-branches/ubuntu/trusty/wget/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/wget-infopod_generated_manpage.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Steve Langasek
  • Date: 2011-05-17 19:46:25 UTC
  • mfrom: (2.1.10 sid)
  • Revision ID: james.westby@ubuntu.com-20110517194625-awyf9lkvyohk71ni
Tags: 1.12-3.1ubuntu1
* Merge from Debian unstable, remaining changes:
  - Add wget-udeb to ship wget.gnu as alternative to busybox wget
    implementation.
  - Keep build dependencies in main:
    + debian/control: remove info2man build-dep
    + debian/patches/series: disable wget-infopod_generated_manpage
  - Depend on libssl-dev 0.9.8k-7ubuntu4 (LP: #503339)
  - Mark wget Multi-Arch: foreign, so packages that aren't of the same arch
    can depend on it.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#!/bin/sh -e
2
 
## wget-infopod_generated_manpage.dpatch by Noèl Köthe <noel debian.org>
3
 
##
4
 
## DP: using info2pod to generate the pod file to have a complete manpage
5
 
 
6
 
if [ $# -lt 1 ]; then
7
 
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
8
 
    exit 1
9
 
fi
10
 
 
11
 
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
12
 
patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
13
 
 
14
 
case "$1" in
15
 
       -patch) patch $patch_opts -p1 < $0;;
16
 
       -unpatch) patch $patch_opts -p1 -R < $0;;
17
 
        *)
18
 
                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
19
 
                exit 1;;
20
 
esac
21
 
 
22
 
exit 0
23
 
 
24
 
@DPATCH@
25
 
diff --git a/doc/Makefile.in b/doc/Makefile.in
26
 
index e89a525..c13a4f9 100644
27
 
--- a/doc/Makefile.in
28
 
+++ b/doc/Makefile.in
29
 
@@ -1032,8 +1032,10 @@
30
 
 $(SAMPLERCTEXI): $(srcdir)/sample.wgetrc
31
 
        sed s/@/@@/g $? > $@
32
 
 
33
 
-wget.pod: $(srcdir)/wget.texi version.texi
34
 
-       $(TEXI2POD) $(srcdir)/wget.texi $@
35
 
+#wget.pod: $(srcdir)/wget.texi version.texi
36
 
+#      $(TEXI2POD) $(srcdir)/wget.texi $@
37
 
+wget.pod: wget.info
38
 
+       info2pod wget.info > $@
39
 
 
40
 
 $(MAN): wget.pod
41
 
        $(POD2MAN) --center="GNU Wget" --release="GNU Wget @VERSION@" $? > $@
42