~ubuntu-branches/ubuntu/wily/gnome-do/wily

« back to all changes in this revision

Viewing changes to debian/patches/01_fix_libX11_linkage.diff

  • Committer: Bazaar Package Importer
  • Author(s): Christopher James Halse Rogers
  • Date: 2011-02-15 21:50:02 UTC
  • mfrom: (1.1.10 upstream)
  • Revision ID: james.westby@ubuntu.com-20110215215002-1j8ylb69o15asb06
Tags: 0.8.4-0ubuntu1
* The Race Against FF upload.  Merge from unreleased Debian git.
  Remaining Ubuntu changes:
  + debian/patches/05_disable_resize_grips.patch.diff:
    Disable resize handles for the Do windows.
  + debian/control:
    Bump gtk# build dep for HasResizeGrip API.
* New Debian changes:
* The long fortold release
  + Fixes a threadsafety issue resulting in 100% CPU usage (Closes: 565591,
    LP: #450852).
  + Proxies all keyring calls to the GTK main thread, as required by the new
    gnome-keyring (Closes: 603876, LP: #553643)
* debian/patches/00_bundledlibs.dpatch:
* debian/rules:
  + Upstream has dropped bundled gmcs binary; now 100% DFSG-free, so we don't
    have to repack the tarball or patch the buildsystem.
* debian/patches/03_disable_docky.dpatch:
  + Drop.  Docky is now gone in the upstream tarball.
* debian/rules:
* debian/control:
* debian/patches/*:
  + Switch to quilt to harmonise with other pkg-cli-* packages.
* debian/control:
  + Drop recommends on gnome-do-docklets.  Docky is now a separate package,
    so the docklets are useless for Do.
  + Bump Breaks on gnome-do-plugins to 0.8.3.  Do no longer provides the Wink
    library, which has been imported into the 0.8.3 do-plugins sources.
  + Bump standards-version; no changes needed.
  + Migrate to git and update VCS fields appropriately

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 03_fix_libX11_linkage.dpatch by Christopher James Halse Rogers <raof@ubuntu.com>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Explicitly link to libX11 to resolve missing symbols
 
6
## DP: on link.
 
7
 
 
8
@DPATCH@
 
9
diff -urNad gnome-do-0.4.0.1~/libdo/Makefile.in gnome-do-0.4.0.1/libdo/Makefile.in
 
10
--- gnome-do-0.4.0.1~/libdo/Makefile.am 2008-03-18 13:31:06.000000000 +1100
 
11
+++ gnome-do-0.4.0.1/libdo/Makefile.am  2008-03-18 13:57:00.000000000 +1100
 
12
@@ -18,6 +18,6 @@
 
13
        eggaccelerators.c
 
14
 
 
15
 libdo_la_LDFLAGS = -export-dynamic -module -avoid-version
 
16
-libdo_la_LIBADD = $(LIBDO_LIBS)
 
17
+libdo_la_LIBADD = $(LIBDO_LIBS) -lX11
 
18
 
 
19
 maintainer-clean-local:
 
20
diff -urNad gnome-do-0.4.0.1~/libdo/Makefile.in gnome-do-0.4.0.1/libdo/Makefile.in
 
21
--- gnome-do-0.4.0.1~/libdo/Makefile.in 2008-03-18 13:31:06.000000000 +1100
 
22
+++ gnome-do-0.4.0.1/libdo/Makefile.in  2008-03-18 13:57:00.000000000 +1100
 
23
@@ -261,7 +261,7 @@
 
24
        eggaccelerators.c
 
25
 
 
26
 libdo_la_LDFLAGS = -export-dynamic -module -avoid-version
 
27
-libdo_la_LIBADD = $(LIBDO_LIBS)
 
28
+libdo_la_LIBADD = $(LIBDO_LIBS) -lX11
 
29
 all: all-am
 
30
 
 
31
 .SUFFIXES: