~ubuntu-branches/ubuntu/wily/gnome-do/wily

« back to all changes in this revision

Viewing changes to debian/patches/04_dont_disable_deprecated.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Christopher James Halse Rogers
  • Date: 2011-02-15 21:50:02 UTC
  • mfrom: (1.1.10 upstream)
  • Revision ID: james.westby@ubuntu.com-20110215215002-1j8ylb69o15asb06
Tags: 0.8.4-0ubuntu1
* The Race Against FF upload.  Merge from unreleased Debian git.
  Remaining Ubuntu changes:
  + debian/patches/05_disable_resize_grips.patch.diff:
    Disable resize handles for the Do windows.
  + debian/control:
    Bump gtk# build dep for HasResizeGrip API.
* New Debian changes:
* The long fortold release
  + Fixes a threadsafety issue resulting in 100% CPU usage (Closes: 565591,
    LP: #450852).
  + Proxies all keyring calls to the GTK main thread, as required by the new
    gnome-keyring (Closes: 603876, LP: #553643)
* debian/patches/00_bundledlibs.dpatch:
* debian/rules:
  + Upstream has dropped bundled gmcs binary; now 100% DFSG-free, so we don't
    have to repack the tarball or patch the buildsystem.
* debian/patches/03_disable_docky.dpatch:
  + Drop.  Docky is now gone in the upstream tarball.
* debian/rules:
* debian/control:
* debian/patches/*:
  + Switch to quilt to harmonise with other pkg-cli-* packages.
* debian/control:
  + Drop recommends on gnome-do-docklets.  Docky is now a separate package,
    so the docklets are useless for Do.
  + Bump Breaks on gnome-do-plugins to 0.8.3.  Do no longer provides the Wink
    library, which has been imported into the 0.8.3 do-plugins sources.
  + Bump standards-version; no changes needed.
  + Migrate to git and update VCS fields appropriately

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## Description: Do not build with *DISABLE_DEPRECATED. libdo uses
3
 
## deprecated symbols and FTBFS with these flags set. It's wrong to
4
 
## set them in release tarballs anyway.
5
 
## Origin/Author: Iain Lane <laney@ubuntu.com
6
 
## Bug: https://bugs.launchpad.net/do/+bug/647495
7
 
## 04_dont_disable_deprecated.dpatch by Iain Lane <laney@ubuntu.com>
8
 
 
9
 
@DPATCH@
10
 
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' gnome-do-0.8.3.1+dfsg~/libdo/Makefile.am gnome-do-0.8.3.1+dfsg/libdo/Makefile.am
11
 
--- gnome-do-0.8.3.1+dfsg~/libdo/Makefile.am    2010-09-29 18:04:35.000000000 +0100
12
 
+++ gnome-do-0.8.3.1+dfsg/libdo/Makefile.am     2010-09-29 18:05:08.036714881 +0100
13
 
@@ -2,9 +2,6 @@
14
 
 
15
 
 AM_CFLAGS = -DG_LOG_DOMAIN=\"libdo\"   \
16
 
            -DEGG_COMPILATION           \
17
 
-           -DGTK_DISABLE_DEPRECATED    \
18
 
-           -DGDK_DISABLE_DEPRECATED    \
19
 
-           -DG_DISABLE_DEPRECATED      \
20
 
            $(LIBDO_CFLAGS)
21
 
 
22