~ubuntu-branches/ubuntu/maverick/evolution-data-server/maverick-proposed

« back to all changes in this revision

Viewing changes to debian/patches/25_mute-debug-messages.patch

  • Committer: Bazaar Package Importer
  • Author(s): Didier Roche
  • Date: 2010-05-17 17:02:06 UTC
  • mfrom: (1.1.79 upstream) (1.6.12 experimental)
  • Revision ID: james.westby@ubuntu.com-20100517170206-4ufr52vwrhh26yh0
Tags: 2.30.1-1ubuntu1
* Merge from debian experimental. Remaining change:
  (LP: #42199, #229669, #173703, #360344, #508494)
  + debian/control:
    - add Vcs-Bzr tag
    - don't use libgnome
    - Use Breaks instead of Conflicts against evolution 2.25 and earlier.
  + debian/evolution-data-server.install,
    debian/patches/45_libcamel_providers_version.patch:
    - use the upstream versioning, not a Debian-specific one 
  + debian/libedata-book1.2-dev.install, debian/libebackend-1.2-dev.install,
    debian/libcamel1.2-dev.install, debian/libedataserverui1.2-dev.install:
    - install html documentation
  + debian/rules:
    - don't build documentation it's shipped with the tarball

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -ruN evolution-data-server-2.22.0.orig/libedataserver/e-categories.c evolution-data-server-2.22.0/libedataserver/e-categories.c
2
 
--- evolution-data-server-2.22.0.orig/libedataserver/e-categories.c     2007-11-29 13:53:48.000000000 +0100
3
 
+++ evolution-data-server-2.22.0/libedataserver/e-categories.c  2008-03-11 21:01:54.000000000 +0100
 
1
diff --git a/libedataserver/e-categories.c b/libedataserver/e-categories.c
 
2
index 24ee076..5ef17cd 100644
 
3
--- a/libedataserver/e-categories.c
 
4
+++ b/libedataserver/e-categories.c
4
5
@@ -30,6 +30,8 @@
5
6
 
6
7
 #include "libedataserver-private.h"
8
9
+#define d(x)
9
10
+
10
11
 typedef struct {
11
 
        char *category;
12
 
        char *icon_file;
13
 
@@ -162,7 +164,7 @@
 
12
        gchar *category;
 
13
        gchar *icon_file;
 
14
@@ -202,7 +204,7 @@ idle_saver_cb (gpointer user_data)
14
15
 
15
16
        filename = build_categories_filename ();
16
 
 
 
17
        
17
18
-       g_debug ("Saving categories to \"%s\"", filename);
18
 
+       d (g_debug ("Saving categories to \"%s\"", filename) );
 
19
+       d (g_debug ("Saving categories to \"%s\"", filename));
19
20
 
20
21
        /* build the file contents */
21
22
        buffer = g_string_new ("<categories>\n");
22
 
@@ -268,7 +270,7 @@
 
23
@@ -303,7 +305,7 @@ load_categories (void)
23
24
        if (!g_file_test (filename, G_FILE_TEST_EXISTS))
24
25
                goto exit;
25
26
 
26
27
-       g_debug ("Loading categories from \"%s\"", filename);
27
 
+       d ( g_debug ("Loading categories from \"%s\"", filename) );
 
28
+       d (g_debug ("Loading categories from \"%s\"", filename));
28
29
 
29
30
        if (!g_file_get_contents (filename, &contents, &length, &error)) {
30
31
                g_warning ("Unable to load categories: %s", error->message);
31
 
@@ -324,7 +326,7 @@
 
32
@@ -359,7 +361,7 @@ migrate_old_categories (void)
32
33
        if (string == NULL || *string == '\0')
33
34
                goto exit;
34
35
 
35
36
-       g_debug ("Loading categories from GConf key \"%s\"", key);
36
 
+       d (g_debug ("Loading categories from GConf key \"%s\"", key) );
 
37
+       d (g_debug ("Loading categories from GConf key \"%s\"", key));
37
38
 
38
39
        n_added = parse_categories (string, strlen (string));
39
40
        if (n_added == 0)
40
 
@@ -401,20 +403,20 @@
 
41
@@ -440,20 +442,20 @@ initialize_categories (void)
41
42
 
42
43
        n_added = load_categories ();
43
44
        if (n_added > 0) {
44
45
-               g_debug ("Loaded %d categories", n_added);
45
 
+               d ( g_debug ("Loaded %d categories", n_added) );
 
46
+               d (g_debug ("Loaded %d categories", n_added));
46
47
                save_is_pending = FALSE;
47
48
                return;
48
49
        }
50
51
        n_added = migrate_old_categories ();
51
52
        if (n_added > 0) {
52
53
-               g_debug ("Loaded %d categories", n_added);
53
 
+               d ( g_debug ("Loaded %d categories", n_added) );
 
54
+               d (g_debug ("Loaded %d categories", n_added));
54
55
                save_categories ();
55
56
                return;
56
57
        }
57
58
 
58
59
        load_default_categories ();
59
60
-       g_debug ("Loaded default categories");
60
 
+       d ( g_debug ("Loaded default categories") );
 
61
+       d (g_debug ("Loaded default categories"));
61
62
        save_categories ();
62
63
 }
63
64