~ubuntu-branches/ubuntu/hardy/mailman/hardy-updates

« back to all changes in this revision

Viewing changes to debian/patches/05_config_list_member_options.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2006-07-03 16:59:25 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20060703165925-175ubna955u796c0
Tags: 0:2.1.8-1ubuntu1
* Merge to Debian; remaining Ubuntu changes:
  - debian/mailman.init: Create /var/{run,lock}/mailman.
  - debian/control: exim4 -> postfix.
* debian/control: Dependency fix: apache -> apache2.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
## 05_config_list_member_options.dpatch by Tollef Fog Heen <tfheen@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Make it possible to set new_member_options as well. 
6
 
## DP: 
7
 
 
8
 
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
9
 
patch_opts="${patch_opts:--f --no-backup-if-mismatch ${2:+-d $2}}"
10
 
 
11
 
if [ $# -lt 1 ]; then
12
 
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
13
 
    exit 1
14
 
fi
15
 
case "$1" in
16
 
    -patch) patch $patch_opts -p1 < $0;;
17
 
    -unpatch) patch $patch_opts -p1 -R < $0;;
18
 
    *)
19
 
        echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
20
 
        exit 1;;
21
 
esac
22
 
 
23
 
exit 0
24
 
@DPATCH@
25
 
 
26
 
--- mailman-2.1.4.orig/bin/config_list
27
 
+++ mailman-2.1.4/bin/config_list
28
 
@@ -293,6 +293,11 @@
29
 
                                     in mm_cfg.OPTINFO.items()
30
 
                                     if validval & bitval]
31
 
                     gui._setValue(mlist, k, validval, fakedoc)
32
 
+                    # Ugly hack, but seems to be needed since
33
 
+                    # new_member_options isn't really a number in gui.
34
 
+                    # -- tfheen, 2003-12-06
35
 
+                    if k == "new_member_options":
36
 
+                        mlist.new_member_options = validval
37
 
             # BAW: when to do gui._postValidate()???
38
 
     finally:
39
 
         if savelist and not checkonly: