~ubuntu-branches/ubuntu/hardy/mailman/hardy-updates

« back to all changes in this revision

Viewing changes to debian/patches/50_README.EXIM.paths.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2006-07-03 16:59:25 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20060703165925-175ubna955u796c0
Tags: 0:2.1.8-1ubuntu1
* Merge to Debian; remaining Ubuntu changes:
  - debian/mailman.init: Create /var/{run,lock}/mailman.
  - debian/control: exim4 -> postfix.
* debian/control: Dependency fix: apache -> apache2.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
## 50_README.EXIM.paths.dpatch by Tollef Fog Heen <tfheen@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Makes sure we're called with the right UID and GID
6
 
 
7
 
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
8
 
patch_opts="${patch_opts:--f --no-backup-if-mismatch ${2:+-d $2}}"
9
 
 
10
 
if [ $# -lt 1 ]; then
11
 
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
12
 
    exit 1
13
 
fi
14
 
case "$1" in
15
 
    -patch) patch $patch_opts -p1 < $0;;
16
 
    -unpatch) patch $patch_opts -p1 -R < $0;;
17
 
    *)
18
 
        echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
19
 
        exit 1;;
20
 
esac
21
 
 
22
 
exit 0
23
 
@DPATCH@
24
 
--- mailman-2.1.5/README.EXIM.orig      2004-10-17 19:09:42.000000000 +0000
25
 
+++ mailman-2.1.5/README.EXIM   2004-10-17 19:09:15.000000000 +0000
26
 
@@ -4,7 +4,8 @@
27
 
 [This is derived from Nigel Metheringham's "HOWTO - Using Exim and
28
 
  Mailman together", which covers Mailman 2.0.x and Exim 3.  It
29
 
  has been updated to cover Mailman 2.1 and Exim 4.  The original
30
 
- document is here: http://www.exim.org/howto/mailman.html]
31
 
+ document is here: http://www.exim.org/howto/mailman.html and
32
 
+ has been modified to reflect pathes used by the Debian package.]
33
 
 
34
 
 
35
 
 Mailman configuration
36
 
@@ -14,7 +15,13 @@
37
 
 options detailed in the Mailman install documentation.  The Exim
38
 
 configuration is transparent to Mailman.  The user and group settings
39
 
 for Mailman must match those in the config fragments given below.
40
 
-   
41
 
+
42
 
+Although not really required for operation you may want to set 
43
 
+
44
 
+  MTA=None
45
 
+
46
 
+in your /etc/mailman/mm_cfg.py to suppress any mention of aliases
47
 
+in messages generated on list creation.
48
 
 
49
 
 Exim configuration
50
 
 ------------------
51
 
@@ -33,7 +40,7 @@
52
 
 
53
 
 The configuration file excerpts below are for use in an already
54
 
 functional Exim configuration, which accepts mail for the domain in
55
 
-which the list resides.  If this domain is separate from the others
56
 
+which the list resides.  If this domain is not the only domain
57
 
 handled by your Exim configuration, then you'll need to:
58
 
 
59
 
   * add the list domain, "my.list.domain" to local_domains
60
 
@@ -72,13 +79,13 @@
61
 
 
62
 
   # Home dir for your Mailman installation -- aka Mailman's prefix
63
 
   # directory.
64
 
-  MAILMAN_HOME=/usr/local/mailman
65
 
+  MAILMAN_HOME=/var/lib/mailman
66
 
   MAILMAN_WRAP=MAILMAN_HOME/mail/mailman
67
 
 
68
 
   # User and group for Mailman, should match your --with-mail-gid
69
 
   # switch to Mailman's configure script.
70
 
-  MAILMAN_USER=mailman
71
 
-  MAILMAN_GROUP=mailman
72
 
+  MAILMAN_USER=list
73
 
+  MAILMAN_GROUP=daemon
74
 
 
75
 
 
76
 
 Transport for Exim 3
77
 
@@ -171,7 +178,7 @@
78
 
     This is bad because it will cause Exim to switch into queue mode and
79
 
     severely delay delivery of your list messages.
80
 
     The way to fix this is to set mailman's SMTP_MAX_SESSIONS_PER_CONNECTION
81
 
-    (in ~mailman/Mailman/mm_cfg.py) to a smaller value than Exim's
82
 
+    (in /etc/mailman/mm_cfg.py) to a smaller value than Exim's
83
 
     smtp_accept_queue_per_connection
84
 
 
85
 
   * Mailman should ignore Exim delay warning messages, even though
86
 
@@ -271,11 +278,11 @@
87
 
 Doing VERP with Exim and Mailman
88
 
 --------------------------------
89
 
 
90
 
-VERP will send one email, with a separate envelope sender (return path),
91
 
-for each of your subscribers -- read the information in
92
 
-~mailman/Mailman/Default.py for the options that start with VERP.  In a
93
 
-nutshell, all you need to do to enable VERP with Exim is to add these
94
 
-lines to ~mailman/Mailman/mm_cfg.py:
95
 
+VERP will send one email, with a separate envelope sender (return
96
 
+path), for each of your subscribers -- read the information in
97
 
+/var/lib/mailman/Mailman/Defaults.py for the options that start with
98
 
+VERP.  In a nutshell, all you need to do to enable VERP with Exim is
99
 
+to add these lines to /etc/mailman/mm_cfg.py:
100
 
 
101
 
   VERP_PASSWORD_REMINDERS = 1
102
 
   VERP_PERSONALIZED_DELIVERIES = 1
103
 
@@ -288,6 +295,10 @@
104
 
 Virtual Domains
105
 
 ---------------
106
 
 
107
 
+NOTE: The approach described here is not applicable to the Debian
108
 
+      package, it's only included for reference. Be warned: you're on
109
 
+      your own if you follow this route.
110
 
+
111
 
 One approach to handling virtual domains is to use a separate Mailman
112
 
 installation for each virtual domain.  (Currently, this is the only way
113
 
 to have lists with the same name in different virtual domains handled by