~ubuntu-branches/ubuntu/hardy/mailman/hardy-updates

« back to all changes in this revision

Viewing changes to debian/patches/21_newlist_help.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2006-07-03 16:59:25 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20060703165925-175ubna955u796c0
Tags: 0:2.1.8-1ubuntu1
* Merge to Debian; remaining Ubuntu changes:
  - debian/mailman.init: Create /var/{run,lock}/mailman.
  - debian/control: exim4 -> postfix.
* debian/control: Dependency fix: apache -> apache2.

Show diffs side-by-side

added added

removed removed

Lines of Context:
21
21
 
22
22
exit 0
23
23
@DPATCH@
24
 
diff -urNad /home/tfheen/external/pkg-mailman/trunk/bin/newlist trunk/bin/newlist
25
 
--- /home/tfheen/external/pkg-mailman/trunk/bin/newlist 2004-08-18 14:49:28.000000000 +0200
26
 
+++ trunk/bin/newlist   2004-08-18 14:50:26.000000000 +0200
27
 
@@ -62,6 +62,9 @@
 
24
diff -urNad mailman-2.1.6~/bin/newlist mailman-2.1.6/bin/newlist
 
25
--- mailman-2.1.6~/bin/newlist  2005-12-10 13:37:50.000000000 +0100
 
26
+++ mailman-2.1.6/bin/newlist   2005-12-25 15:55:10.056996722 +0100
 
27
@@ -87,6 +87,9 @@
28
28
 defined in your Defaults.py file or overridden by settings in mm_cfg.py).
29
29
 
30
30
 Note that listnames are forced to lowercase.
34
34
 """
35
35
 
36
36
 import sys
37
 
@@ -69,6 +72,7 @@
 
37
@@ -94,6 +97,7 @@
38
38
 import getpass
39
39
 import getopt
40
40
 import sha
42
42
 
43
43
 import paths
44
44
 from Mailman import mm_cfg
45
 
@@ -97,6 +101,9 @@
 
45
@@ -122,6 +126,9 @@
46
46
 
47
47
 
48
48
 def main():
49
49
+    gid = grp.getgrnam(mm_cfg.MAILMAN_GROUP)[2]
50
 
+    if os.getgid() != mm_cfg.MAILMAN_GROUP:
 
50
+    if os.getgid() != gid:
51
51
+        os.setgid(gid)
52
52
     try:
53
 
         opts, args = getopt.getopt(sys.argv[1:], 'hql:',
54
 
                                    ['help', 'quiet', 'language='])
55
 
@@ -163,7 +170,7 @@
 
53
         opts, args = getopt.getopt(sys.argv[1:], 'hql:u:e:',
 
54
                                    ['help', 'quiet', 'language=',
 
55
@@ -199,7 +206,7 @@
56
56
         except Errors.BadListNameError, s:
57
57
             usage(1, _('Illegal list name: %(s)s'))
58
58
         except Errors.EmailAddressError, s: