~ubuntu-branches/ubuntu/oneiric/gnome-panel/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/03_dnd_places_link.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastien Bacher, Sebastien Bacher, Jeremy Bicha
  • Date: 2011-05-30 11:04:49 UTC
  • mfrom: (1.13.10 upstream) (2.2.5 experimental)
  • Revision ID: james.westby@ubuntu.com-20110530110449-hinl17kxkcefjw6x
Tags: 1:3.0.2-0ubuntu1
[ Sebastien Bacher ]
* New upstream version
* debian/control.in:
  - the new libgweather version is in oneiric, use it
  - drop the python and python-gconf depends, 
    they were added for gnome-panel-add which is still using gconf and buggy
* debian/gnome-panel-data.install:
  - don't install the apport hook, it's only getting gconf datas which 
    doesn't work since gnome-panel uses gsettings
* debian/patches/90_build_fixes.patch:
  - restore build fix from git not applied in the new serie
* debian/patches/01_panel_submenus.patch:
  - don't take that Debian diff, the .menus use the upstream naming in Ubuntu
* debian/patches/06_no_resize_grip.patch:
  - dropped, the issue is fixed in the new version
* debian/patches/50_fix-potfiles.patch:
  - dropped, the issue is fixed in the new version
* debian/watch:
  - track unstable series as well

Drop those delta, since gnome-panel is not the default Ubuntu session now we
can go back to an experience closer to the upstream one: 
* debian/control.in:
  - drop the indicators recommends, unity-2d is the ubuntu fallback session
    so we can get back to use an upstream config for gnome-panel and reduce
    the delta we carry
* debian/patches/04_default_panel_config.patch:
  - don't modify the upstream layout
* debian/patches/05_no_session_delay.patch:
  - no need to tweak the upstream session to optimize it
* debian/patches/16_compiz_workspace_switcher.patch:
  - go back to the upstream switcher behaviour    
* debian/patches/25_dynamic_fusa_detection.patch:
  - not needed since we use the upstream layout, could be ported if someone
    is wanting to do the work though
* debian/patches/30_disable-initial-animation.patch, debian/rules:
  - drop the --disable-initial-animation, that was some login optimization
    but since it's not the default desktop you should go back to the 
    upstream behaviour

[ Jeremy Bicha ]   
* New upstream version
* Merge from Debian experimental, remaining Ubuntu changes:
* debian/control:
  - Recommends gnome-settings-daemon which has the timezone polkit service
* debian/rules:
  - Update translations template.
* debian/gnome-panel-data.install:
  - Install apport hook
  - Install the "About Ubuntu" menu item.
* debian/patches/01_layout.patch:
  - Disabled, Help & About Ubuntu don't fit as well in Gnome Panel 3
* debian/patches/01_panel_submenus.patch.
  - Dropped
* debian/patches/03_dnd_places_link.patch:
  - Disabled, when using Drag'n'Drop from Places menu, install a link launcher
    (.desktop file) instead of copying the entire directory.
* debian/patches/17_about-ubuntu-translation.patch:
  - List ubuntu-about.desktop for translation.
* debian/patches/40_unset_menuproxy.patch:
  - Make sure gnome-panel and the applets don't pick up menu proxies.
* debian/patches/50_fix-potfiles.patch
  - Fix i18n
* debian/patches/85_disable_shutdown_on_ltsp.patch:
  - Suppress the shutdown option in the panel if LTSP_CLIENT is set.
* debian/patches/71_change_bookmark_submenu_limit_value.patch
  - Dropped, picked up by Debian
* debian/patches/18_lockdown_lock_editor.patch:
* debian/patches/90_git_wnck_show_realize.patch:
* debian/patches/90_fix_linking_DSO_link.patch:
* debian/patches/91_gir_annotations.patch
* debian/patches/92_git_calendar_day.patch
* debian/patches/92_git_fix_applets_in_multiscreen.patch:
  - Dropped, applied upstream
* debian/watch:
  - watch unstable versions

Show diffs side-by-side

added added

removed removed

Lines of Context:
3
3
Bug: https://bugzilla.gnome.org/show_bug.cgi?id=357934
4
4
Bug-Ubuntu: https://launchpad.net/bugs/62529 
5
5
 
6
 
Index: gnome-panel-2.32.0/gnome-panel/menu.c
 
6
Index: gnome-panel-3.0.0.1/gnome-panel/menu.c
7
7
===================================================================
8
 
--- gnome-panel-2.32.0.orig/gnome-panel/menu.c  2010-06-23 01:42:54.000000000 +0200
9
 
+++ gnome-panel-2.32.0/gnome-panel/menu.c       2010-10-15 18:43:13.992592194 +0200
10
 
@@ -1216,7 +1216,8 @@
 
8
--- gnome-panel-3.0.0.1.orig/gnome-panel/menu.c 2011-03-29 10:20:47.000000000 -0400
 
9
+++ gnome-panel-3.0.0.1/gnome-panel/menu.c      2011-05-06 05:17:51.743035471 -0400
 
10
@@ -816,7 +816,8 @@
11
11
 void
12
12
 setup_uri_drag (GtkWidget  *menuitem,
13
13
                const char *uri,
17
17
 {
18
18
        static GtkTargetEntry menu_item_targets[] = {
19
19
                { "text/uri-list", 0, 0 }
20
 
@@ -1228,7 +1229,7 @@
 
20
@@ -828,7 +829,7 @@
21
21
        gtk_drag_source_set (menuitem,
22
22
                             GDK_BUTTON1_MASK|GDK_BUTTON2_MASK,
23
23
                             menu_item_targets, 1,
26
26
 
27
27
        if (icon != NULL)
28
28
                gtk_drag_source_set_icon_name (menuitem, icon);
29
 
Index: gnome-panel-2.32.0/gnome-panel/menu.h
 
29
Index: gnome-panel-3.0.0.1/gnome-panel/menu.h
30
30
===================================================================
31
 
--- gnome-panel-2.32.0.orig/gnome-panel/menu.h  2010-02-09 13:32:08.000000000 +0100
32
 
+++ gnome-panel-2.32.0/gnome-panel/menu.h       2010-10-15 18:43:13.992592194 +0200
 
31
--- gnome-panel-3.0.0.1.orig/gnome-panel/menu.h 2010-02-09 07:32:08.000000000 -0500
 
32
+++ gnome-panel-3.0.0.1/gnome-panel/menu.h      2011-05-06 05:17:51.743035471 -0400
33
33
@@ -51,7 +51,8 @@
34
34
                                            PanelActionButtonType  type);
35
35
 void            setup_uri_drag             (GtkWidget  *menuitem,
40
40
 
41
41
 GtkWidget *    panel_create_menu              (void);
42
42
 
43
 
Index: gnome-panel-2.32.0/gnome-panel/panel-menu-items.c
 
43
Index: gnome-panel-3.0.0.1/gnome-panel/panel-menu-items.c
44
44
===================================================================
45
 
--- gnome-panel-2.32.0.orig/gnome-panel/panel-menu-items.c      2010-10-15 18:43:13.000592195 +0200
46
 
+++ gnome-panel-2.32.0/gnome-panel/panel-menu-items.c   2010-10-15 18:43:13.996592196 +0200
47
 
@@ -261,7 +261,7 @@
 
45
--- gnome-panel-3.0.0.1.orig/gnome-panel/panel-menu-items.c     2011-04-04 17:47:29.000000000 -0400
 
46
+++ gnome-panel-3.0.0.1/gnome-panel/panel-menu-items.c  2011-05-06 05:19:44.066367958 -0400
 
47
@@ -348,7 +348,7 @@
48
48
 
49
49
        uri = g_filename_to_uri (full_path, NULL, NULL);
50
50
 
53
53
        g_free (uri);
54
54
 
55
55
        g_key_file_free (key_file);
56
 
@@ -308,7 +308,8 @@
57
 
        g_signal_connect (G_OBJECT (item), "button_press_event",
 
56
@@ -395,6 +395,8 @@
58
57
                          G_CALLBACK (menu_dummy_button_press_event), NULL);
59
58
 
60
 
-       setup_uri_drag (item, uri, icon_name);
 
59
        setup_uri_drag (item, uri, icon_name);
61
60
+       if (g_str_has_prefix (uri, "file:")) /*Links only work for local files*/
62
61
+               setup_uri_drag (item, uri, icon_name, GDK_ACTION_LINK);
 
62
 
 
63
        return item;
63
64
 }
64
 
 
65
 
 static GtkWidget *