~ubuntu-branches/debian/wheezy/linux-2.6/wheezy

« back to all changes in this revision

Viewing changes to debian/patches/features/arm/sheevaplug-esata-board.patch

  • Committer: Bazaar Package Importer
  • Author(s): Ben Hutchings, Ben Hutchings, Aurelien Jarno, Martin Michlmayr
  • Date: 2011-04-06 13:53:30 UTC
  • mfrom: (43.1.5 sid)
  • Revision ID: james.westby@ubuntu.com-20110406135330-wjufxhd0tvn3zx4z
Tags: 2.6.38-3
[ Ben Hutchings ]
* [ppc64] Add to linux-tools package architectures (Closes: #620124)
* [amd64] Save cr4 to mmu_cr4_features at boot time (Closes: #620284)
* appletalk: Fix bugs introduced when removing use of BKL
* ALSA: Fix yet another race in disconnection
* cciss: Fix lost command issue
* ath9k: Fix kernel panic in AR2427
* ses: Avoid kernel panic when lun 0 is not mapped
* PCI/ACPI: Report ASPM support to BIOS if not disabled from command line

[ Aurelien Jarno ]
* rtlwifi: fix build when PCI is not enabled.

[ Martin Michlmayr ]
* rtlwifi: Eliminate udelay calls with too large values (Closes: #620204)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: John Holland <john.holland@cellent-fs.de>
2
 
Date: Fri, 19 Feb 2010 22:10:58 +0000 (+0100)
3
 
Subject: [ARM] eSATA SheevaPlug basic board support
4
 
 
5
 
commit d8ecb3490050b33bf46ce77c7f239e0fc51a6835 upstream.
6
 
 
7
 
Allow basic eSATA SheevaPlug board configuration and build.
8
 
 
9
 
Signed-off-by: John Holland <john.holland@cellent-fs.de>
10
 
Signed-off-by: Nicolas Pitre <nico@marvell.com>
11
 
---
12
 
 
13
 
diff --git a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
14
 
index f6c6196..1b8adda 100644
15
 
--- a/arch/arm/mach-kirkwood/Kconfig
16
 
+++ b/arch/arm/mach-kirkwood/Kconfig
17
 
@@ -32,6 +32,12 @@
18
 
          Say 'Y' here if you want your kernel to support the
19
 
          Marvell SheevaPlug Reference Board.
20
 
 
21
 
+config MACH_ESATA_SHEEVAPLUG
22
 
+       bool "Marvell eSATA SheevaPlug Reference Board"
23
 
+       help
24
 
+         Say 'Y' here if you want your kernel to support the
25
 
+         Marvell eSATA SheevaPlug Reference Board.
26
 
+
27
 
 config MACH_TS219
28
 
        bool "QNAP TS-119 and TS-219 Turbo NAS"
29
 
        help
30
 
diff --git a/arch/arm/mach-kirkwood/Makefile b/arch/arm/mach-kirkwood/Makefile
31
 
index d4d7f53..704b892 100644
32
 
--- a/arch/arm/mach-kirkwood/Makefile
33
 
+++ b/arch/arm/mach-kirkwood/Makefile
34
 
@@ -5,6 +5,7 @@
35
 
 obj-$(CONFIG_MACH_RD88F6281)           += rd88f6281-setup.o
36
 
 obj-$(CONFIG_MACH_MV88F6281GTW_GE)     += mv88f6281gtw_ge-setup.o
37
 
 obj-$(CONFIG_MACH_SHEEVAPLUG)          += sheevaplug-setup.o
38
 
+obj-$(CONFIG_MACH_ESATA_SHEEVAPLUG)    += sheevaplug-setup.o
39
 
 obj-$(CONFIG_MACH_TS219)               += ts219-setup.o
40
 
 obj-$(CONFIG_MACH_TS41X)               += ts41x-setup.o
41
 
 obj-$(CONFIG_MACH_OPENRD_BASE)         += openrd_base-setup.o
42
 
diff --git a/arch/arm/mach-kirkwood/sheevaplug-setup.c b/arch/arm/mach-kirkwood/sheevaplug-setup.c
43
 
index c7319ee..629ce84 100644
44
 
--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c
45
 
+++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c
46
 
@@ -96,6 +96,7 @@ static void __init sheevaplug_init(void)
47
 
        platform_device_register(&sheevaplug_leds);
48
 
 }
49
 
 
50
 
+#ifdef CONFIG_MACH_SHEEVAPLUG
51
 
 MACHINE_START(SHEEVAPLUG, "Marvell SheevaPlug Reference Board")
52
 
        /* Maintainer: shadi Ammouri <shadi@marvell.com> */
53
 
        .phys_io        = KIRKWOOD_REGS_PHYS_BASE,
54
 
@@ -106,3 +107,16 @@ MACHINE_START(SHEEVAPLUG, "Marvell SheevaPlug Reference Board")
55
 
        .init_irq       = kirkwood_init_irq,
56
 
        .timer          = &kirkwood_timer,
57
 
 MACHINE_END
58
 
+#endif
59
 
+
60
 
+#ifdef CONFIG_MACH_ESATA_SHEEVAPLUG
61
 
+MACHINE_START(ESATA_SHEEVAPLUG, "Marvell eSATA SheevaPlug Reference Board")
62
 
+       .phys_io        = KIRKWOOD_REGS_PHYS_BASE,
63
 
+       .io_pg_offst    = ((KIRKWOOD_REGS_VIRT_BASE) >> 18) & 0xfffc,
64
 
+       .boot_params    = 0x00000100,
65
 
+       .init_machine   = sheevaplug_init,
66
 
+       .map_io         = kirkwood_map_io,
67
 
+       .init_irq       = kirkwood_init_irq,
68
 
+       .timer          = &kirkwood_timer,
69
 
+MACHINE_END
70
 
+#endif