~ubuntu-branches/ubuntu/intrepid/enigma/intrepid

« back to all changes in this revision

Viewing changes to debian/patches/dont-build-zipios.patch

  • Committer: Bazaar Package Importer
  • Author(s): Erich Schubert
  • Date: 2005-08-28 15:30:09 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20050828153009-sky64kb6tcq37xt5
Tags: 0.92.1-1
* New upstream subversion checkout
* Remove menu.s3m, which we are allowed to distributed but not to modify
  also copyright notice is confusing... (Closes: #321669)
* Rebuild with new libzipios (Closes: #325405)
  I hope this works without a versioned build-dependency
* Added "enigma replaces enigma-data" for upgrades (Closes: #308558)
* Added notes about the fonts copyright.
* updated to policy 3.6.2.1 (no changes)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
### This patch changes the build process so that enigma is built using
2
2
### the debian-supplied lua and zipios libraries.
3
 
--- configure.ac.orig   2004-11-29 01:38:01.000000000 +0100
4
 
+++ configure.ac        2004-11-29 01:38:24.000000000 +0100
5
 
@@ -199,7 +199,7 @@
6
 
 AC_DEFINE_UNQUOTED(DEFAULT_DATA_PATH, "./data:~/.enigma:$ENIGMA_DATADIR", [Default data directory])
7
 
 
8
 
 dnl Configure libraries
 
3
--- configure.ac.orig   2005-08-28 15:59:22.000000000 +0200
 
4
+++ configure.ac        2005-08-28 16:00:16.000000000 +0200
 
5
@@ -207 +207 @@
9
6
-AC_CONFIG_SUBDIRS(lib-src/zipios++)
10
7
+dnl AC_CONFIG_SUBDIRS(lib-src/zipios++)
11
 
 dnl AC_CONFIG_SUBDIRS(lib-src/enet)
12
 
 
13
 
 AC_CONFIG_FILES([Makefile m4/Makefile  intl/Makefile 
14
 
--- lib-src/Makefile.am.orig    2004-04-09 21:18:35.000000000 +0200
15
 
+++ lib-src/Makefile.am 2004-05-09 17:27:27.000000000 +0200
 
8
--- lib-src/Makefile.am.orig    2005-08-28 15:59:28.000000000 +0200
 
9
+++ lib-src/Makefile.am 2005-08-28 16:00:30.000000000 +0200
16
10
@@ -1 +1 @@
17
 
-SUBDIRS = oxydlib lua zipios++
18
 
+SUBDIRS = oxydlib lua
19
 
--- src/Makefile.am.orig        2005-05-07 17:44:09.000000000 -0700
20
 
+++ src/Makefile.am     2005-05-07 17:44:45.000000000 -0700
21
 
@@ -76,10 +76,9 @@
22
 
 
 
11
-SUBDIRS = oxydlib lua zipios++ enet enigma-core
 
12
+SUBDIRS = oxydlib lua enet enigma-core
 
13
--- src/Makefile.am.orig        2005-08-28 15:59:40.000000000 +0200
 
14
+++ src/Makefile.am     2005-08-28 16:01:32.000000000 +0200
 
15
@@ -122,4 +122,5 @@
23
16
 endif
24
17
 
25
18
+CXXFLAGS = @SDL_CFLAGS@ -DLOCALEDIR=\"$(localedir)\" -I$(top_srcdir)/lib-src
26
19
 
27
 
 enigma_CXXFLAGS = @SDL_CFLAGS@  -DLOCALEDIR=\"$(localedir)\" \
 
20
 enigma_CXXFLAGS = \
 
21
@@ -128,2 +128,0 @@
28
22
-       -I$(top_srcdir)/lib-src/zipios++  \
29
23
-       -I$(top_builddir)/lib-src/zipios++ \
30
 
        -I$(top_srcdir)/lib-src/lua \
31
 
        -I$(top_srcdir)/lib-src \
32
 
        -I$(top_builddir)/intl
33
 
@@ -91,7 +90,7 @@
34
 
                px/libpx.a \
35
 
                $(top_builddir)/lib-src/lua/liblua.a \
36
 
                $(top_builddir)/lib-src/oxydlib/liboxyd.a \
37
 
-               $(top_builddir)/lib-src/zipios++/src/libzipios.a \
38
 
+               -lzipios
39
 
                -lz \
40
 
                $(mingw_ldadd)
41
 
 
 
24
@@ -146,1 +144,0 @@
 
25
-       $(top_builddir)/lib-src/zipios++/src/libzipios.a \
 
26
@@ -147,2 +145,3 @@
 
27
        -lz \
 
28
+       -lzipios \
 
29
        $(mingw_ldadd)