~ubuntu-branches/ubuntu/natty/moin/natty-updates

« back to all changes in this revision

Viewing changes to debian/patches/20002_hardcode_configdir.patch

  • Committer: Bazaar Package Importer
  • Author(s): Jonas Smedegaard
  • Date: 2008-06-22 21:17:13 UTC
  • mfrom: (0.9.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20080622211713-fpo2zrq3s5dfecxg
Tags: 1.7.0-3
Simplify /etc/moin/wikilist format: "USER URL" (drop unneeded middle
CONFIG_DIR that was wrongly advertised as DATA_DIR).  Make
moin-mass-migrate handle both formats and warn about deprecation of
the old one.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff --git a/setup.py b/setup.py
 
2
index ff7c7a9..20d04d5 100644
 
3
--- a/setup.py
 
4
+++ b/setup.py
 
5
@@ -167,9 +167,8 @@ class build_scripts_create(build_scripts):
 
6
                         % script_vars)
 
7
                 else:
 
8
                     file.write("#! %(python)s\n"
 
9
-                        "#Fix and uncomment those 2 lines if your moin command doesn't find the MoinMoin package:\n"
 
10
-                        "#import sys\n"
 
11
-                        "#sys.path.insert(0, '%(package_location)s')\n"
 
12
+                        "import sys\n"
 
13
+                        "sys.path.insert(0, '/etc/moin')\n"
 
14
                         "from %(package)s.script.%(module)s import run\n"
 
15
                         "run()\n"
 
16
                         % script_vars)